500gb not recognized on 15 core duo

Discussion in 'MacBook Pro' started by simidesignerguy, Jan 30, 2009.

  1. simidesignerguy macrumors newbie

    Joined:
    Nov 27, 2008
    Location:
    Simi Valley
    #1
    I just picked up a 500gb samsung HD to replace my stock 100gb drive.

    I installed the new drive & OSX but when it tries to start up there is only a black folder with a question mark. I've tried reformatting and reinstalling about 3 times with no luck.

    The computer works fine when I reinstall the old 100gb HD. The 500gb drive seems to work fine as an external, but will not boot OSX!

    Do the core duos have an issue with large drives? Do I have a software or hardware problem?

    Thanks!!!
     
  2. thefunkymunky macrumors 65816

    Joined:
    Feb 24, 2005
    Location:
    London
    #2
    Are you able to boot your Mac using the 500GB drive externally?
     
  3. Cave Man macrumors 604

    Cave Man

    #3
    My money says you did not choose GUID partition table when you initialized the drive.
     
  4. Skystar macrumors 6502

    Joined:
    May 15, 2007
    #4
    I installed a samsung 500gb drive (from newegg) in my 2.16 CD, everything went fine. I just used the leopard install disk utility to setup 1 partition and it worked from there. Not sure what partition table it was set to though.
     
  5. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #5
    Probably right, the only other option is that he didnt format the drive in HFS+ or an Apple compatible format. Theres no issue with the computer reading a 500GB drive.
     
  6. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #6
    To be fair it's quite impossible to format it wrong when you use the installation DVD for OS X.
     
  7. simidesignerguy thread starter macrumors newbie

    Joined:
    Nov 27, 2008
    Location:
    Simi Valley
    #7
    -The drive is internally installed.
    -The drive is recognized externally, but will not boot externally. (without partition)

    The drive was formatted by the OSX CD using Mac OSX (Journaled).

    I tried creating 3 partitions (145/145/172 give or take), then installed OSX on one of the 145 partitions and the installation worked perfectly. Im actually using the laptop in question now.

    So, as I'm typing this I went into disk utility and removed the other partitions. Now my startup drive says its capacity is 465gb. good.

    Could the OS be having a problem recognizing the drive on startup? I'm a little worried about restarting my computer!
     
  8. Cave Man macrumors 604

    Cave Man

    #8
    Launch Disk Utility and tell us the drive's partition table (GUID, Apple or Master Boot Record).
     

Share This Page