500GB WD external hard drive troubles

Discussion in 'Mac Accessories' started by madlibman, Jun 3, 2009.

  1. madlibman macrumors newbie

    Joined:
    Jun 3, 2009
    #1
    I've got a WD 500 GB external hard drive that has worked perfectly for about a year. I don't use time machine or any other backup software. I prefer to organize it myself and backup files individually.

    Suddenly, today, it's freaking out at me. I've got several folders in it that I copy things too. One of them being Music. I was copying a few gigs of new music into that folder, but when it finished copying I couldn't access any of the other files.

    It's like I'm stuck in the sub menu where I can just see the music I have on the drive and nothing else. The rest of the files are there somewhere because I only have about 50gbs of music and it says that 300gbs of space are being used, but I can't see them and i've tried a bunch of different things to get them to show up. Any ideas? Thanks,

    Jason
     
  2. soccerguy1690 macrumors newbie

    Joined:
    Jun 3, 2009
    #2
    I can't help you with your problem, but I have a problem of my own to add here. My friend has a 500GB Western Digital external hard drive that he uses for his PC. I want to move music files off of his hard drive on to my Mac. I can't figure out how to access the files. I can see all the folders there when I open up the My Book in the Finder window, but there are no files inside. I have Memeo Lifeagent installed (looks pretty useless though) on my Mac, but I can't for the life of me figure out a way that would allow this to work for both a PC and a Mac at the same time.
     
  3. -tWv- macrumors 68000

    -tWv-

    Joined:
    May 11, 2009
    Location:
    Ohio
    #3
    If the drive is formatted in NTFS i would try and install NTFS-3G (http://www.ntfs-3g.org/). It's a free driver that allows you to read and write on windows formatted disks. I use it to copy things from my OSX partition to my bootcamp partition. I would try to install that and see if you can find anything on the drive.
     

Share This Page