5770 Texture Errors

Discussion in 'Mac Pro' started by vogelhausdesign, Sep 27, 2010.

  1. vogelhausdesign macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #1
    Hey everyone, so I'm testing my GPU(s) today and I'm noticing that my real world testing of the HD 5770 is much lower than reported by apple, and even slightly lower than reported by Barefeats.

    I'd like to ask everyone here a few questions since I'm not an expert on GPU tech.

    During a benchmark/Stress test I was running blu-ray and gaming at the same time when I noticed something off on my first gaming run of the 5770. I restarted my machine, let it cool off, and restarted my game (CoD 4MW) and I'm noticing a lot of broken textures.. boxes and walls are black.

    To shorten this post, after 2 re-installs, complete overhaul of my configuration of the game graphically, nothing has changed..

    Is this a driver/firmware issue? is it just 5770 support for CoD? or does it sound like I have a bad card? I'm getting really terrible performance out of this thing..
     
  2. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #2
    Nobody? update: it seems like where their should be shadow maps there is just black texture.. if anyone wants to help I can post screens
     
  3. schulmaster macrumors member

    Joined:
    Aug 7, 2010
    #3
    @ Vogel: I can assure you it is not a CoD conbatibility isssue. I've played the whole series on ATI cards.
    What exactly was "off' before your first restart?
    Have you tried rolling back the drivers one revision? What drivers are you using?
     
  4. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #4
    I'm running mac version of CoD 4 MW online, I noticed that half of the textures used on boxes, walls, and crates were all just blacked out.. no texture at all. Re-installed the game twice, tried many different configurations within the game and I got nothing.. not to mention my FPS is embarrassing for a workstation card
     
  5. goMac macrumors 603

    Joined:
    Apr 15, 2004
  6. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #6
  7. schulmaster macrumors member

    Joined:
    Aug 7, 2010
    #7
    That's definitely a GPU malfunction, but might not be a hardware issue. I sopke too soon earlier, and didn't realize you were running the OSX version of CoD, with which I am not familiar. If you havent seen any artifacts or lost textures in any other program, then it's probably an issue with the game. Have you tried any other applications? Even a benchmarking program would work. I know Furmark is a good one for windows, I'm sure there is something similar for OSX. If you can get through a stress test with no problems, then it is almost definitely not your hardware that's the problem.
     
  8. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #8
    I'm going to install bootcamp today to run that test. I'll report back when I'm done and see if there is something going on. If there is I'll be at the apple store tomorrow morning with this card in a paper bag.
     
  9. goMac macrumors 603

    Joined:
    Apr 15, 2004
    #9
    Last time I was in the Apple store with a GPU issue, they made me bring the whole machine because they didn't have a Mac Pro to test in. Call ahead and check.
     
  10. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #10
    Hey everyone sorry to bring this thread back, however my issues are ongoing. Here is my update, aside from disappointing performance from the 5770 I've noticed that it passes ever benchmark/memory test I toss at it without reported errors.

    I reinstalled call of duty 4, and still have the same issues. Most of the blue textures are black and the shadows are drawn poorly.

    Cinema 4d, adobe CS5 and all basic graphical functions of OS X are acting normal.

    Can anyone else give some insight? Should I take my machine in? Please refer to my earlier picture post for visual example
     
  11. brock2621 macrumors 6502a

    brock2621

    Joined:
    Jun 8, 2007
    Location:
    Kentucky
    #11
    Try some other games, preferably ones based on the same game engine if possible. Then try bootcamp and see if u are still getting them.
     
  12. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #12
    here is another example. I pointed to an area where there should be wall texture/material. But instead, there is only black.

    [​IMG]

    I Plan on installing bootcamp, but i would only use windows to TEST the card.. I don't have anything else I'd need windows for currently, so I ask.. if I can only game in windows, should I send this machine in for repairs? Or wait for better drivers..
     

    Attached Files:

  13. vogelhausdesign thread starter macrumors regular

    vogelhausdesign

    Joined:
    Jan 7, 2009
    Location:
    Columbus, Ohio
    #13
    sorry again for the bump.. anyone want to weigh in on this?
     

Share This Page