5770 w/ 5.1 Mac Pro Screen Flashes Black, Glitches, Little specs of static

Discussion in 'Mac Pro' started by RoastingPig, Nov 10, 2014.

  1. RoastingPig macrumors 68000

    RoastingPig

    Joined:
    Jul 23, 2012
    Location:
    SoCal
    #1
    Hi im having this annoying problem with my 5.1 mac pro w/ oem 5770. Im not sure if its the apple 27 cinema display or the video card itself. But about every 15 minutes the screen goes black for 1 second and comes back.. As i am writing this i saw the screen tear at the bottom half like if i was gaming on a pc with screen tearing happening in a game.
     
  2. Earl Urly macrumors regular

    Joined:
    Jul 11, 2004
    #2
    Can you see if this happens with another monitor? Can you check that the fan is running smoothly or if it's stuck? It sounds like an overheating GPU to me.
     
  3. RoastingPig thread starter macrumors 68000

    RoastingPig

    Joined:
    Jul 23, 2012
    Location:
    SoCal
    #3
    im going to try the mac pro out with my tv and keep an eye on the 5770 fan...am also currently testing the cinema display with my imac i have and its not replicating any of the problems that it has on my mac pro.
     
  4. sebseb macrumors 6502

    sebseb

    Joined:
    May 24, 2014
    #4
    Well in case it is the Graphics card, you can find cheap oem 5770 on ebay and replace the device...unless you have apple care!

    Imagine if this was the nMP w/ no apple care! you can start using it as a trashcan!
     
  5. RoastingPig, Nov 10, 2014
    Last edited: Nov 10, 2014

    RoastingPig thread starter macrumors 68000

    RoastingPig

    Joined:
    Jul 23, 2012
    Location:
    SoCal
    #5
    im glad i sold my nMP.

    Using only a 720p television and doing very light stuff like just browsing macrumors forum i am not experiencing anything as i previously mentioned. The 5770 as shown on istat is only running at 51c with the 720p television by itself. and with the apple cinema 27' display is runs at around 76c by itself and thats when i start seeing the glitches and 1second blackouts

    *Update
    i could not replicate anything using the tv only even getting the temperature up to 190 for a few minutes using heaven benchmarks. Could it be something with the vram?
     
  6. RoastingPig thread starter macrumors 68000

    RoastingPig

    Joined:
    Jul 23, 2012
    Location:
    SoCal
    #6
    WOW, i re-thermal pasted my ati 5770 and im running like 30F-35 Degrees cooler at idle. Apple from the factory had gunked it up really bad.
     
  7. sebseb macrumors 6502

    sebseb

    Joined:
    May 24, 2014
    #7
    If you have a 2010 Mac Pro, then it's been 4 years and the thermal paste can start to loose its heat conductivity, which will lead to the chip heating up!

    It's good to re apply thermal paste each 3 years. It's what I did with my MBP!
     

Share This Page