5g 60 GB iPod Display problem!

Discussion in 'iPod' started by k2spitfire88, Apr 21, 2008.

  1. k2spitfire88 macrumors 6502

    Joined:
    Feb 15, 2008
    Location:
    in your mind
    #1
    Hey all, my 5g 60GB video iPod just had a display issue pop up. I was using my iPod and the screen was fine. I shut it off, went to work, and then I used it after my 1 1/2 hour shift at school, turned it on, and there was this multi-colored "splotch" in the middle of the screen. However, it is only there when the backlight is on. So the screen is good when it is off, or no backlight, but if the backlight is on, or I am watching a movie, there is this splotch on my screen! Any ideas how to fix this? Or what could cause this?
     
  2. susanp macrumors newbie

    Joined:
    Jan 30, 2009
    #2
    We have the same problem. Except it's a white line through the middle, but can't see it when it's not backlit.

    Thank you for ANY help!
     
  3. k2spitfire88 thread starter macrumors 6502

    Joined:
    Feb 15, 2008
    Location:
    in your mind
    #3
    What they told me was that the LCD went bad, and it would be like $114 (or something ridiculous like that) to replace it, since there was no more warranty on it (for me). I just made do until I got my iPod Touch for Christmas. Sorry I couldn't be of more help. :(
     
  4. richardhunt macrumors regular

    Joined:
    Oct 2, 2007
    #4
    My guess is that something applied pressure to that point messed up the screen. You can buy new lcd screens for 5g ipods under $20 all day long on e-bay. It's not that difficult to replace it. A lot less than buying a new ipod.
     
  5. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #5
    I got in my car one day and went to use my iPod, and freaked out when I saw multi-colored splotches all over the screen! To my relief I realized that I had my sunglasses on; when I took them off all was normal. Phew!
     

Share This Page