Resolved 5K iMac and MX Master Mouse

Discussion in 'iMac' started by Surfer13134, Oct 3, 2015.

  1. Surfer13134, Oct 3, 2015
    Last edited: Oct 3, 2015

    Surfer13134 macrumors 6502a

    Joined:
    Jun 12, 2010
    Location:
    Florida
    #1
    Hi all. I have a problem that I have spent ALL day racking my head on and cant figure it out. I have a logitech MX Master Mouse that is connected via the wireless dongle and has been great for months,after I updated to 10.11 the mouse was acting a little weird and now I can use the scroll wheel at all on the mouse. My apple wireless mouse works just fine with no issues. I have reinstalled the logictech program,Hell I even did a system restore from time machine back to when the mouse was working. Now when I got to my macbook (NON 10.11) it works fine! So I can rule out Hardware issue. I have tried connected the mouse via bluetooth as well and still the same problem. Now if I disconnect and reconnect the mouse again for a brief second the scroll wheel works then it just stops. Does anyone know how to fix this? Im going NUTS. Thanks for any help you can shed on this!

    Edit: I posted this in the OSX section but its empty in there and Im racking my head. Thanks
     
  2. drleach macrumors newbie

    Joined:
    Oct 4, 2015
    #2
    logitech has an updated driver on their website. After installing, I had to unplug the dongle and replug. Then everything worked fine.
     
  3. Surfer13134 thread starter macrumors 6502a

    Joined:
    Jun 12, 2010
    Location:
    Florida
    #3
    THANK YOU SO MUCH!!! That was it!
     

Share This Page