5K iMac, finder is super slow?

Discussion in 'iMac' started by skinnfell, Dec 15, 2014.

  1. skinnfell macrumors newbie

    Joined:
    Jun 14, 2011
    #1
    So i got a new 5K iMac, base config except SSD instead of Fusion drive.
    Display is beautiful. Video runs smoothly. Processing (Lightroom) is fast.

    However the finder is super slow and laggy. Opening up new finder windows, previewing picture files, moving files, scrolling in file lists: all this has lags of several seconds, or up to almost a minute. Sometimes even the cursor is slow.

    HD is about 25% full, I have hardly used it on the web (IE little chance of virus). I mosly use it in Lightroom and PS to edit photos, and finder to shuffle and organise JPG, MOV files, etc.
    I have shut off transparency, spotlight, and otherwise followed all other available advice to speed up the machine. It still feels like a 1994 macintosh with full hard drive instead of a 2014 imac with a brand new ssd.
    I have to force quit finder several times per session. In fact the issues are so annoying that i have had to move my files to an external and using my 2008 imac to shuffle files, renaming, preview videos etc.

    I suspected this could be a Yosemite issue, but after installing that on a 2011 Air, I see no issues with that computer.
    So how come this iMac is able to spit out raw conversions faster than ever before, and play video smooth as silk, but still need several seconds to draw out a single finder window?

    Yosemite bug or hardware issue?

    Any input appreciated as I am quite distraught here.
     
  2. sth macrumors 6502a

    Joined:
    Aug 9, 2006
    Location:
    The old world
    #2
    Sounds like a hardware issue. Try running Apple Hardware Test (AHT).
     
  3. CuteBaby macrumors member

    Joined:
    Jan 2, 2010
    #3
    Another possibility is that you might have some sort of software installed on your boot drive that is causing the issue.

    Try creating a new user account via System Preferences > Users & Groups, then selecting Log Out from the Apple menu, then logging into the new user.

    If there is no longer a Finder slowdown, then the issue is related to the main user account. Check your main user's Login Items (again via System Preferences > Users & Groups) to see if you have anything listed there that could be causing the issue.

    If, on the other hand, the Finder slowdown persists even with the new user account, then try restoring your SSD to a fresh state by formatting and installing OS X again (after first backing up any necessary data, of course).

    If there is no longer a Finder slowdown after the formatting and reinstallation of the OS, then it is unlikely to be a hardware issue. You could then move your apps and files back from your backup in batches while monitoring/testing each time, rather than perform a full migration/restoration.

    If, on the other hand, the Finder slowdown persists immediately after the formatting and reinstallation of the OS, try removing any custom hardware you may have added, or contacting Apple for further assistance.
     
  4. rei101 macrumors 6502a

    Joined:
    Dec 24, 2011
    #4
    I used to have a bug where the computer kept indexing in the background all the time. I had it in two Macs.... horrible!
     
  5. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    Hi skinnfell, from what you've described my first guess would be that the issues are related to a bug in Yosemite. However I was hoping you'd be kind enough to try some of the troubleshooting steps below which I hope will identify any problems. I appreciate your patience.

    1) Is OS X fully up-to-date? Apple menu>App Store>Updates.
    2) Try Disk Utility verification. Search Disk Utility in spotlight or Finder>Applications>Utilities>Disk Utility. Single-click the Macintosh HD partition and click 'Verify Disk'. Any issues found?
    3) Restart your Mac (Apple menu>Restart) with the option 'Reopen windows when logging back in' disabled. If there is a background process that is conflicting with OS X, causing the UI lags, restarting with this option disabled should help identify this.
    4) Further to the above, you can try restarting with Login items deleted to see if there's a conflict (Apple Menu>System Preferences>Users & Groups>Login items)
    5) You can check for hardware issues on your SSD by downloading & running SMART Utility (download it here): https://www.macupdate.com/download/24875/smartutility312.zip
    6) You can run a permissions repair through Disk Utility (just click repair permissions, don't worry about verify permissions), then restart your computer.

    If you'd be happy to try any of the above at your earliest convenience and quote this to let me know the outcome, we'll go from there.

    Again I really appreciate you taking the time to do this.
     
  6. skinnfell thread starter macrumors newbie

    Joined:
    Jun 14, 2011
    #6
    thank you

    A systems check showed no disk errors. ("Hard drive appears to be ok")
    I have updated the system to 10.10.1 and uninstalled spotify.
    I do not know which action did it, but after this update the great lag seems to be gone, and I have not had any more finder crashes, so it seems it was all related to a software bug.

    However, finder still lags a little bit, but not to the point where it is unusable. I am hoping this will be further improved in future OS updates.

    A big thank you to keysofanxiety for providing detailed help.
    (PS, is that Filosofem in your profile pic?)
     
  7. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #7
    It's okay buddy, I'm pleased that an update made it a little better. May I confirm you tried restarting your computer with reopen windows disabled?

    And yeah it is Filosofem! :D I feel far too happy that somebody recognised it. Haha.
     
  8. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #8
    rei wrote above:
    [[ I used to have a bug where the computer kept indexing in the background all the time. I had it in two Macs.... horrible! ]]

    The solution is simple:
    TURN OFF Spotlight.

    You can do that with the command line, or a couple of utility apps such as:
    - Deeper
    - Spotless.

    Be aware that by disabling Spotlight, you loose some functions. But I've never "lost anything" that made me want Spotlight back!
     
  9. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007

Share This Page