5K iMac Freezes w/Sierra

childoftheko4n

macrumors regular
Original poster
Oct 18, 2011
227
48
Hey All,

On a late 2015 5K iMac that seems to be having some problems since the sierra update. Since the update i have had a handful of freezes. The first few were while gaming (in WoW) but the most recent was a minute or so after closing WoW so it may or may not be related. This time, instead of manually turning it off, i let it sit for awhile and it restarted; generating a report. Below is the report. Can anyone give me some insight?

Thanks!

Anonymous UUID: 32EB4002-B7D7-2B25-3777-AB7422B01F02

Fri Oct 21 15:17:25 2016

*** Panic Report ***
panic(cpu 4 caller 0xffffff801aa09f4a): Kernel trap at 0xffffff801ae39d6a, type 13=general protection, registers:
CR0: 0x000000008001003b, CR2: 0x00000001250ffcd4, CR3: 0x000000001f654000, CR4: 0x00000000003627e0
RAX: 0xc0ffee1bf792aaa4, RBX: 0xffffff7f9d0463d8, RCX: 0x0000000000000016, RDX: 0x00000000000fff8e
RSP: 0xffffff93dca0bd70, RBP: 0xffffff93dca0bd80, RSI: 0xffffff7f9d0463d8, RDI: 0xffffff806398b800
R8: 0x0000000000000000, R9: 0x0000000000000000, R10: 0x0000000000000010, R11: 0x0000000000000008
R12: 0xffffff93dd480071, R13: 0xffffff93cbe5da38, R14: 0xffffff806398b800, R15: 0xffffff805c814000
RFL: 0x0000000000010286, RIP: 0xffffff801ae39d6a, CS: 0x0000000000000008, SS: 0x0000000000000010
Fault CR2: 0x00000001250ffcd4, Error code: 0x0000000000000000, Fault CPU: 0x4, PL: 0

Backtrace (CPU 4), Frame : Return Address
0xffffff83b4e45df0 : 0xffffff801a8f748c
0xffffff83b4e45e70 : 0xffffff801aa09f4a
0xffffff83b4e46050 : 0xffffff801a8a9743
0xffffff83b4e46070 : 0xffffff801ae39d6a
0xffffff93dca0bd80 : 0xffffff7f9da1dbc3
0xffffff93dca0be00 : 0xffffff7f9da1d858
0xffffff93dca0be20 : 0xffffff7f9cfec8e9
0xffffff93dca0be70 : 0xffffff7f9cff5a04
0xffffff93dca0beb0 : 0xffffff7f9cff5240
0xffffff93dca0bee0 : 0xffffff801aebedbf
0xffffff93dca0bf30 : 0xffffff801aebd621
0xffffff93dca0bf80 : 0xffffff801aebcd7c
0xffffff93dca0bfb0 : 0xffffff801a8a6af7
Kernel Extensions in backtrace:
com.apple.iokit.IOAcceleratorFamily2(288.13)[27E0AFCE-E36A-35F5-A008-BB1EB3A2C7B9]@0xffffff7f9cfe9000->0xffffff7f9d079fff
dependency: com.apple.iokit.IOPCIFamily(2.9)[731443D8-78D5-30C8-939A-1ED3E857CA22]@0xffffff7f9b132000
dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[377FAA09-C02F-3FF4-A5DE-C0F2E711C8B0]@0xffffff7f9bce1000
com.apple.AMDRadeonX4000(1.4.4)[228A574F-E9EA-3B25-B07A-CE08ADFFC6D3]@0xffffff7f9da18000->0xffffff7f9e268fff
dependency: com.apple.iokit.IOSurface(152)[CD2E7A07-1BD9-3298-A038-E6F8098F0C2A]@0xffffff7f9bb3a000
dependency: com.apple.iokit.IOPCIFamily(2.9)[731443D8-78D5-30C8-939A-1ED3E857CA22]@0xffffff7f9b132000
dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[377FAA09-C02F-3FF4-A5DE-C0F2E711C8B0]@0xffffff7f9bce1000
dependency: com.apple.iokit.IOAcceleratorFamily2(288.13)[27E0AFCE-E36A-35F5-A008-BB1EB3A2C7B9]@0xffffff7f9cfe9000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
16A323

Kernel version:
Darwin Kernel Version 16.0.0: Mon Aug 29 17:56:20 PDT 2016; root:xnu-3789.1.32~3/RELEASE_X86_64
Kernel UUID: 622D2470-C34D-31F9-A62B-6AA9A3C6A3CD
Kernel slide: 0x000000001a600000
Kernel text base: 0xffffff801a800000
__HIB text base: 0xffffff801a700000
System model name: iMac17,1 (Mac-B809C3757DA9BB8D)

System uptime in nanoseconds: 314345038919914
last loaded kext at 314193468982497: com.apple.driver.AppleTopCaseHIDEventDriver 102 (addr 0xffffff7f9ee73000, size 57344)
last unloaded kext at 288699939297454: com.apple.driver.usb.cdc 5.0.0 (addr 0xffffff7f9ed26000, size 28672)
loaded kexts:
org.pqrs.driver.Karabiner 10.21.0
com.logitech.driver.LogiGamingMouseFilter 1
com.driver.LogJoystick 2.0
com.apple.driver.AppleTopCaseHIDEventDriver 102
com.apple.driver.AppleHSBluetoothDriver 102
com.apple.filesystems.smbfs 3.1
com.apple.filesystems.afpfs 11.0.1
com.apple.nke.asp-tcp 8.0.1
com.apple.filesystems.msdosfs 1.10
com.apple.filesystems.exfat 1.4
com.apple.filesystems.autofs 3.0
com.apple.iokit.IOBluetoothSerialManager 5.0.0f18
com.apple.driver.AGPM 110.23.7
com.apple.driver.X86PlatformShim 1.0.0
com.apple.driver.ApplePlatformEnabler 2.7.0d0
com.apple.driver.AppleOSXWatchdog 1
com.apple.driver.AppleMikeyHIDDriver 127
com.apple.driver.AppleMikeyDriver 276.26
com.apple.driver.AppleGraphicsDevicePolicy 3.13.60
com.apple.driver.AppleHDA 276.26
com.apple.driver.AppleUpstreamUserClient 3.6.4
com.apple.kext.AMDFramebuffer 1.4.4
com.apple.driver.pmtelemetry 1
com.apple.iokit.IOUserEthernet 1.0.1
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.driver.AppleIntelSKLGraphics 10.1.8
com.apple.driver.AppleHV 1
com.apple.driver.AppleThunderboltIP 3.0.8
com.apple.AMDRadeonX4000 1.4.4
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 5.0.0f18
com.apple.kext.AMD9000Controller 1.4.4
com.apple.driver.AppleIntelPCHPMC 1.1
com.apple.driver.AppleSMCLMU 208
com.apple.driver.AppleIntelSKLGraphicsFramebuffer 10.1.8
com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0
com.apple.driver.AppleMCCSControl 1.2.13
com.apple.driver.AudioAUUC 1.70
com.apple.driver.AppleUSBDisplays 380
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
com.apple.BootCache 39
com.apple.filesystems.hfs.kext 366.1.1
com.apple.driver.AppleUSBStorageCoexistentDriver 404.1.1
com.apple.iokit.IOAHCIBlockStorage 295.1.1
com.apple.driver.AppleFWOHCI 5.5.5
com.apple.driver.AppleSDXC 1.7.6
com.apple.iokit.AppleBCM5701Ethernet 10.2.6
com.apple.driver.AirPort.Brcm4360 1100.37.1a16
com.apple.driver.AppleAHCIPort 326
com.apple.driver.AppleACPIButtons 5.0
com.apple.driver.AppleRTC 2.0
com.apple.driver.AppleHPET 1.8
com.apple.driver.AppleSMBIOS 2.1
com.apple.driver.AppleACPIEC 5.0
com.apple.driver.AppleAPIC 1.7
com.apple.nke.applicationfirewall 171
com.apple.security.quarantine 3
com.apple.security.TMSafetyNet 8
com.apple.driver.AppleMultitouchDriver 367.6
com.apple.driver.AppleInputDeviceSupport 76.1
com.apple.driver.IOBluetoothHIDDriver 5.0.0f18
com.apple.security.SecureRemotePassword 1.0
com.apple.kext.triggers 1.0
com.apple.iokit.IOSerialFamily 11
com.apple.driver.DspFuncLib 276.26
com.apple.kext.OSvKernDSPLib 525
com.apple.iokit.IOUSBHIDDriver 900.4.1
com.apple.iokit.IOSurface 152
com.apple.driver.AppleGraphicsControl 3.13.60
com.apple.iokit.IOBluetoothHostControllerUSBTransport 5.0.0f18
com.apple.iokit.IOBluetoothHostControllerTransport 5.0.0f18
com.apple.iokit.IOBluetoothFamily 5.0.0f18
com.apple.driver.AppleHDAController 276.26
com.apple.iokit.IOHDAFamily 276.26
com.apple.driver.AppleThunderboltEDMSink 4.1.1
com.apple.iokit.IOFireWireIP 2.2.7
com.apple.kext.AMDSupport 1.4.4
com.apple.driver.AppleSMBusPCI 1.0.14d1
com.apple.driver.X86PlatformPlugin 1.0.0
com.apple.driver.IOPlatformPluginFamily 6.0.0d8
com.apple.AppleGraphicsDeviceControl 3.13.60
com.apple.iokit.IOAcceleratorFamily2 288.13
com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0
com.apple.iokit.IONDRVSupport 2.4.1
com.apple.driver.AppleSMC 3.1.9
com.apple.driver.AppleSMBusController 1.0.14d1
com.apple.iokit.IOGraphicsFamily 2.4.1
com.apple.driver.AppleUSBAudio 305.62
com.apple.iokit.IOAudioFamily 205.11
com.apple.vecLib.kext 1.2.0
com.apple.driver.AppleThunderboltDPInAdapter 4.5.3
com.apple.driver.AppleThunderboltDPOutAdapter 4.5.3
com.apple.driver.AppleThunderboltDPAdapterFamily 4.5.3
com.apple.driver.AppleThunderboltPCIUpAdapter 2.0.3
com.apple.driver.AppleThunderboltPCIDownAdapter 2.0.3
com.apple.driver.usb.IOUSBHostHIDDevice 1.1
com.apple.driver.CoreStorage 540
com.apple.filesystems.hfs.encodings.kext 1
com.apple.iokit.IOSCSIBlockCommandsDevice 394
com.apple.iokit.IOUSBMassStorageClass 4.0.4
com.apple.iokit.IOUSBMassStorageDriver 131.1.1
com.apple.iokit.IOSCSIArchitectureModelFamily 394
com.apple.driver.usb.networking 5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice 1.1
com.apple.driver.usb.AppleUSBHub 1.1
com.apple.driver.usb.AppleUSBEHCIPCI 1.1
com.apple.driver.usb.AppleUSBEHCI 1.1
com.apple.iokit.IOFireWireFamily 4.6.4
com.apple.driver.AppleThunderboltNHI 4.1.3
com.apple.iokit.IOThunderboltFamily 6.2.1
com.apple.iokit.IOEthernetAVBController 1.0.3b4
com.apple.iokit.IO80211Family 1200.12.2
com.apple.driver.mDNSOffloadUserClient 1.0.1b8
com.apple.iokit.IONetworkingFamily 3.2
com.apple.driver.corecapture 1.0.4
com.apple.driver.AppleUSBMergeNub 900.4.1
com.apple.driver.AppleUSBHostMergeProperties 1.1
com.apple.iokit.IOAHCIFamily 288
com.apple.driver.usb.AppleUSBXHCIPCI 1.1
com.apple.driver.usb.AppleUSBXHCI 1.1
com.apple.driver.usb.AppleUSBHostPacketFilter 1.0
com.apple.iokit.IOUSBFamily 900.4.1
com.apple.iokit.IOUSBHostFamily 1.1
com.apple.driver.AppleBusPowerController 1.0
com.apple.driver.AppleEFINVRAM 2.1
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.driver.AppleEFIRuntime 2.0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.security.sandbox 300.0
com.apple.kext.AppleMatch 1.0.0d1
com.apple.driver.AppleKeyStore 2
com.apple.driver.AppleMobileFileIntegrity 1.0.5
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.DiskImages 444
com.apple.iokit.IOStorageFamily 2.1
com.apple.iokit.IOReportFamily 31
com.apple.driver.AppleFDEKeyStore 28.30
com.apple.driver.AppleACPIPlatform 5.0
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOACPIFamily 1.4
com.apple.kec.Libm 1
com.apple.kec.pthread 1
com.apple.kec.corecrypto 1.0
Model: iMac17,1, BootROM IM171.0105.B09, 4 processors, Intel Core i7, 4 GHz, 32 GB, SMC 2.34f2
Graphics: AMD Radeon R9 M395X, AMD Radeon R9 M395X, PCIe, 4096 MB
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1867 MHz, 0x859B, 0x424C533847334E3138414553342E31364645
Memory Module: BANK 0/DIMM1, 8 GB, DDR3, 1867 MHz, 0x859B, 0x424C533847334E3138414553342E31364645
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1867 MHz, 0x859B, 0x424C533847334E3138414553342E31364645
Memory Module: BANK 1/DIMM1, 8 GB, DDR3, 1867 MHz, 0x859B, 0x424C533847334E3138414553342E31364645
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x14A), Broadcom BCM43xx 1.0 (7.21.171.10.1a16)
Bluetooth: Version 5.0.0f18, 3 services, 27 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
PCI Card: Apple 57761-B0, Ethernet Controller, Thunderbolt@191,0,0
PCI Card: pci11c1,5901, IEEE 1394 Open HCI, Thunderbolt@190,0,0
PCI Card: pci12d8,400e, USB Open Host Controller, Thunderbolt@194,0,0
PCI Card: pci12d8,400e, USB Open Host Controller, Thunderbolt@194,0,1
PCI Card: pci12d8,400f, USB Enhanced Host Controller, Thunderbolt@194,0,2
Serial ATA Device: APPLE SSD SM0512G, 500.28 GB
USB Device: USB 3.0 Bus
USB Device: Elements 107C
USB Device: BUP Slim BK
USB Device: Elements 107C
USB Device: Bluetooth USB Host Controller
USB Device: FaceTime HD Camera (Built-in)
USB Device: iPad
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: HD Webcam C615
USB Device: USB Receiver
USB Device: FaceTime HD Camera (Display)
USB Device: Apple Thunderbolt Display
USB Device: USB Receiver
USB Device: Display Audio
Thunderbolt Bus: iMac, Apple Inc., 28.1
Thunderbolt Device: Thunderbolt Display, Apple Inc., 1, 26.2
 

hdmdc

macrumors newbie
Feb 22, 2011
16
0
Portugal
I have the exact same problem.

I have been trying to figure out what is happening and its a problem with the new drivers that Sierra has, with el captain this doesn't happen, and also on windows it doesn't happen. I have been using the new public beta that seams to have new drivers for our Macs and it seams to solve the problem and so far I haven't had any crashes. My advise if for you to backup your system and try the public beta..or just wait for the final release:)

Btw my model is the M395 one

I also contacted blizzard and they are aware of the problem.
 

childoftheko4n

macrumors regular
Original poster
Oct 18, 2011
227
48
I have the exact same problem.

I have been trying to figure out what is happening and its a problem with the new drivers that Sierra has, with el captain this doesn't happen, and also on windows it doesn't happen. I have been using the new public beta that seams to have new drivers for our Macs and it seams to solve the problem and so far I haven't had any crashes. My advise if for you to backup your system and try the public beta..or just wait for the final release:)

Btw my model is the M395 one

I also contacted blizzard and they are aware of the problem.
oh? new beta has updated drivers?! this makes me happy, and also settles my insanity seeing I'm not the only one lol I knew this couldn't be a hardware issue M395X here as well so could very well be a graphics driver

*meant to ask. was there any activity that was triggering it for you to freeze?
 

hdmdc

macrumors newbie
Feb 22, 2011
16
0
Portugal
Yes, mostly the whole Mac freezed when I was alt tabbing from wow to safari or other program. Initially I trough this could be a messed up graphic card, since I had the iMac for fews days the retailer gave me another iMac. And then it crashed again..so I started to see what software could be causing it..and then I remembered that was when I was quitting wow, alt tabing or had it running previously.. thats when I contacted blizzard and spoke with the specific technical support team and the acknowledge that there was a problem with some AMD cards.

So yeah I guess with the new beta things are solved..but this happens randomly and as such I need more time to test:)
 

hdmdc

macrumors newbie
Feb 22, 2011
16
0
Portugal
For now yes. Also I see some graphical improvements..before when I would wake up the Mac after several hours it would take sometime and some lines would appear on the screen before it prompt the password field. Strange stuff (happened on both iMacs) with beta this is also solved.
 

childoftheko4n

macrumors regular
Original poster
Oct 18, 2011
227
48
awesome. def installing tonight Just in time for me to leave for a week w/o worrying about it haha
 

hdmdc

macrumors newbie
Feb 22, 2011
16
0
Portugal
You also may try on wow in Sierra to change the api to OpenGL instead of metal. It solves this issue for some users(Blizzard info)