6 day-old iPod Classic, already a few lock-ups.

Discussion in 'iPod' started by skiltrip, Jun 8, 2010.

  1. skiltrip macrumors 68030

    Joined:
    May 6, 2010
    Location:
    New York
    #1
    I got a new 160GB Classic last week. I've had it a total of 6 days. The first freeze-ups I encountered were while playing iQuiz. I came to terms with the fact that I don't like the game at all, so I blew it off, though I was curious why it would do that (seemed to happen when it was using my tracks to play samples for questions).

    But I've also had two freeze-ups since, when connecting it to my MacBook Pro (2010). Just, as soon as it's plugged in, it locks up, and won't do a thing. Have to do a two-finger reset and then it's fine. I've never had any other freeze-ups other than the iQuiz ones, and when I connect it to my computer. I must say that I've sync'd probably 3 times a day on average, and I've only had those 2 freeze-ups. But still.

    Does this sound normal at all, or could I possible have a glitchy iPod Classic? I mean, it's only 6 days old, I didn't think I'd experience ANY crashes at all.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    LOL

    iPod is the most popular music player because it's glitchy and freezes regularly. NOT.

    Return / Exchange for a new one if you have the rare ones with problems.
     
  3. skiltrip thread starter macrumors 68030

    Joined:
    May 6, 2010
    Location:
    New York
    #3
    Thanks everyone. I think I'll do that this morning. Hopefully it'll be quick and simple. I mean, I had my first freeze up the second day I had it. And it's less than a week old.
     

Share This Page