6+ Wifi Calling while in Airplane Mode

Discussion in 'iPhone' started by JunBringer, Mar 10, 2015.

  1. JunBringer macrumors member

    JunBringer

    Joined:
    Oct 7, 2014
    #1
    So if I turn on airplane mode and then turn on wifi it shows "T-Mobile Wifi" at the top, thus I won't miss any calls or texts in theory. I did unlock my device after doing this though and it didn't say T-Mobile Wifi for a moment which makes me think it goes to sleep or something like that, thus defeating the purpose which is saving battery. Has anyone else tried this? Is there a way to make sure it doesn't timeout or stop connecting to whatever it connects to for wifi calling/texting?
     
  2. ckc macrumors regular

    Joined:
    Nov 13, 2010
    #2
    Wifi automatically cuts off when the device goes into sleep mode, which is why you see the slight delay when you wake the phone up again. It is a power savibf feature.

    The only exception to this is if you keep the phone connected to a mains power source, wifi then stays active.
     
  3. CEmajr macrumors 601

    Joined:
    Dec 18, 2012
    Location:
    Charlotte, NC
    #3
    Slightly unrelated but how are you needing to turn on airplane mode to save battery with a 6 Plus? The thing lasts all day even with poor signal and heavy usage.
     
  4. JunBringer thread starter macrumors member

    JunBringer

    Joined:
    Oct 7, 2014
    #4
    That doesn't make sense since you can get iMessages while the device is in sleep mode, right?

    I'm trying to see how many days I can get out of it without charging, I know it's dumb but it'd be cool, that's all.
     
  5. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #5
    Hmm...mine usually stays connected to WiFi calling unless there's some unusually high traffic on our network. Otherwise, it kind of defeats the purpose of WiFi calling...which is to be able to get service. I have the 6 but when I wake it from sleeping, it still says T-Mobile WiFi 95% of the time.

    You should do a test if you have a 2nd phone or landline available. Make sure it's connected to WiFi calling in airplane mode, let it go to sleep for a while. Then call yourself or text yourself. If it goes to VM, you may want to try resetting your network settings.
     
  6. JunBringer thread starter macrumors member

    JunBringer

    Joined:
    Oct 7, 2014
    #6
    I'll try to fiddle with it tonight some more, thanks everyone!
     
  7. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #7
    Would it also do it if the phone has no cellular connection and is basically just on WiFi?
     

Share This Page