64-Bit Windows 7 Load Driver Installation Problem

Discussion in 'Windows, Linux & Others on the Mac' started by MacKey76, Aug 8, 2011.

  1. MacKey76 macrumors newbie

    Joined:
    Aug 8, 2011
    #1
    I am new to Mac and have recently got my hands on a new 17" MBP.

    The MBP is a 2011 model dating from about May.

    Not wanting to step 100% away from Windows I want to install Windows 7 as well and run Mac OS.

    I have tried installing Windows 7 32-Bit and it worked absolutely fine - no problems at all.

    However, when I tried to install 64-Bit Windows 7 I ran into a problem very early on in the installation.

    Before the part where you select the partition to install Windows on, I get a "Load Driver" message which reads:

    "A required CD/DVD drive device driver is missing. If you have a floppy disk, CD, DVD, or USB flash drive, please insert it now."

    I cannot eject the DVD to replace it with the Windows Support DVD that I burned (which I assume has the relevant drivers on), so I am a bit stuck.

    I tried googling and a few people suggested burning the disk at a slower speed, which I did and it made no difference at all.

    The fact that 32-Bit works lets me know I am doing things right, there must be something about the 64-Bit that the MBP doesn't like.

    Any help much appreciated. I have 8GB RAM and would like to use it all with both Mac OS AND Windows so 64-Bit is preferred.

    Thanks in advance.
     
  2. MacKey76 thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-gb) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    Any ideas anyone? Or a recommendation of a forum which may be knowledgeable in this area?

    Thanks
     
  3. blastoboy1000 macrumors newbie

    Joined:
    Aug 7, 2011
    #3
    If you can identify which specific driver Windows is looking for, you could copy it to a flash drive, or make a small FAT32 partition on your hard drive where you could put the necessary drivers, if it can't read the CD drive initially.

    If it's an issue of Windows not allowing unsigned drivers to be installed (which it shouldn't, because you're installing Apple drivers), you can follow this tutorial (http://www.killertechtips.com/2009/...gning-in-windows-7-using-group-policy-editor/). 32-bit Windows allows the installation of unsigned drivers by default, but 64-bit doesn't (for some legitimate reason, I'm sure).
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    Restart the computer holding down the trackpad button; that will force the DVD to be ejected.
    EDIT: Of course, this probably isn't going to solve your missing driver problem, because that should be part of the base Windows installation.
     
  5. MacKey76 thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #5
    I still have made no progress with this.

    The error message suggests it is looking for a driver for the actual CD/DVD drive. I have tried all the drivers which Bootcamp burned for me as part of the Windows Support disk (I put them all on a USB stick so I didn't have to try and get the DVD out), and none of the seem to be what it's looking for.

    Is there a Windows 64-bit driver for the CD/DVD drive on this MBP and if so where can I find it? And if not, has anyone successfully installed 64-bit Windows 7 on their MBP and how did they do it?

    Thanks
     
  6. blastoboy1000, Aug 13, 2011
    Last edited: Aug 13, 2011

    blastoboy1000 macrumors newbie

    Joined:
    Aug 7, 2011
    #6
    I successfully installed Windows 7 64-bit on my MacBook, using Boot Camp as prescribed. The driver you're looking for is, appropriately, called cdrom.sys, located within C:\Windows\System32\Drivers.

    EDIT: I couldn't figure out how to PM you the link, but I've uploaded my working 64-bit driver here: http://www.megaupload.com/?d=9HO4IEO3
    Hopefully that'll work for you.
     
  7. Westone macrumors newbie

    Joined:
    Aug 12, 2011
    #7
    It may not be relevant to the MBP, but I am brand new to Mac and OS X, and I successfully installed Windows 7 64 bit on a MBA using BootCamp. The steps in the BootCamp Assistant went off without a hitch.
     
  8. MacKey76 thread starter macrumors newbie

    Joined:
    Aug 8, 2011
    #8
    Thanks for the help, but it is looking for an INF file for a driver rather than the SYS driver file itself.

    I am stuck!
     
  9. blastoboy1000 macrumors newbie

    Joined:
    Aug 7, 2011
    #9

Share This Page