650M GPU idling

Discussion in 'Mac Basics and Help' started by thebelt24, Apr 30, 2016.

  1. thebelt24 macrumors newbie

    Joined:
    Aug 5, 2012
    #1
    I have a Macbook Pro Retina 15'' mid 2012 using bootcamp Windows 8.1

    I've recently been noticing how my GPU the GT 650M is staying in P8 when I game which results in 68MHz clock with 98% load causing extreme lag. I've tried locking the P-state by creating a bat file with "nvidiaInspector.exe -forcepstate:0,1" in the same folder as NVIDIA Inspector (which was the highest recommended strategy on the forums). However the issue persisted, so I tried using NIVIDIA Bios editor however I got an error when it tried reading the bios. Any suggestions? I need to lock the P-state so my clocks will run at their best 900MHz/2000MHz instead of 13% of their maximum. fuck me.png
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    The reason the BIOS edit failed is because the Mac doesn't actually have a traditional BIOS. I think you'd be better off trying to update your nVidia drivers / Inspector first and see if that improves things. Apple's default drivers aren't necessarily the best or most up to date, especially for gaming.
     
  3. thebelt24 thread starter macrumors newbie

    Joined:
    Aug 5, 2012
    #3
    updated NVIDIA Inspector and drivers, no change. When I hit "Apply Clocks and Voltage" the clocks change to my desired settings but in a matter of 3-20 seconds they revert back to idle unless I'm using such high graphics it's forced out of idle. However even in that instance it fluctuates between 240-720 MHz, which causes major lag in games, while remaining at 68-69 degrees. I've also disabled throttling so I'm out of ideas.
     
  4. thebelt24 thread starter macrumors newbie

    Joined:
    Aug 5, 2012
    #4
    Having used a few different driver versions I'm convinced this is a driver related issue. As of now I'm using GeForce 332.21 (an older driver) and it seems the clock is locked at 405 MHz in P8 thus giving me much more reliable speed but still only utilizing half of the full gpu clock potential.
     

Share This Page