680mx bad performance

Discussion in 'iMac' started by Pishtirgenskii, Jul 22, 2013.

  1. Pishtirgenskii, Jul 22, 2013
    Last edited: Jun 20, 2014
  2. Mac32 macrumors 6502a

    Joined:
    Nov 20, 2010
    #2
    I assume you are using bootcamp? Those framerates are obviously way too low. Stating the obvious-alert: Remember to turn off antialiasing when playing newer games in 1440p.
     
  3. forty2j macrumors 68030

    forty2j

    Joined:
    Jul 11, 2008
    Location:
    NJ
    #3
    If you're in Bootcamp, install the GeForce Experience and have it check your driver versions and your settings in every game.

    Out of curiosity - Win 7 or 8?
     
  4. forty2j macrumors 68030

    forty2j

    Joined:
    Jul 11, 2008
    Location:
    NJ
    #4
    To be perfectly honest, outside of the chance you have a lemon, the behavior you describe is close to what you'd get if you tried to game through Parallels/VMWare instead of Bootcamp.
     
  5. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #5
    Ensure you're using BootCamp, as others have said.

    Then go on this website: http://www.nvidia.com/Download/Scan.aspx?lang=en-us
     
  6. Pishtirgenskii, Jul 22, 2013
    Last edited: Jun 20, 2014

    Pishtirgenskii thread starter macrumors newbie

    Joined:
    Jul 22, 2013
  7. elithrar macrumors 6502

    elithrar

    Joined:
    May 31, 2007
    #7
    Can you post the exact settings you're using in these games? Far Cry 3 included. Screenshots are best.

    If you're just maxing out every slider it may be that the 680MX just can't do it at 1440p. It's a good card, but some of the games you've listed can be pretty demanding on Ultra.
     
  8. Pishtirgenskii, Jul 22, 2013
    Last edited: Jun 20, 2014

    Pishtirgenskii thread starter macrumors newbie

    Joined:
    Jul 22, 2013
  9. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
  10. forty2j macrumors 68030

    forty2j

    Joined:
    Jul 11, 2008
    Location:
    NJ
    #10
    On the OS X side, please go into :apple:->About this Mac->More Info and post a screenshot of that. (You should blot out your serial #.)

    I can think of a few possibilities, but they're all pretty unlikely:
    - You don't actually have the Mac you think you have (mixup at factory or something)
    - You somehow managed to enable the Intel integrated graphics on your Ivy Bridge chip and turned control over to that instead of the Nvidia. This happens all the time with the laptops but to my knowledge shouldn't happen on the iMacs.
    - You have a lemon.
    - Your Windows partition is seriously corrupted.

    For fun, and to try to eliminate option 4 above, try to get some FPS numbers from OS X. All the games you listed are Windows exclusive, but you can try WoW (free to play up to level 20) or maybe just the Heaven benchmark tool.
     
  11. Pishtirgenskii, Jul 23, 2013
    Last edited: Jun 20, 2014

    Pishtirgenskii thread starter macrumors newbie

    Joined:
    Jul 22, 2013
  12. forty2j macrumors 68030

    forty2j

    Joined:
    Jul 11, 2008
    Location:
    NJ
    #12
    Fascinating.. that puts you firmly in Windows debugging territory.. not enough or too many antivirus software, driver files corrupted, etc. etc. Good luck.. stuff like that is why I stay out of Windows as much as possible..

    BTW I was interested in your "About this Mac" information - everything EXCEPT the serial number. There's a (small) risk to you from posting the serial #.
     
  13. elithrar macrumors 6502

    elithrar

    Joined:
    May 31, 2007
    #13
    Or bad drivers.

    Use Driver Fusion (http://treexy.com/products/driver-fusion) to clear out the terrible Boot Camp drivers and then install the latest nVidia WHQL drivers.
     
  14. Pishtirgenskii, Jul 26, 2013
    Last edited: Jun 20, 2014

    Pishtirgenskii thread starter macrumors newbie

    Joined:
    Jul 22, 2013

Share This Page