680mx + WoW

Discussion in 'iMac' started by jetjaguar, Dec 14, 2012.

  1. jetjaguar, Dec 14, 2012
    Last edited: Dec 14, 2012

    jetjaguar macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #1
    anyone with a new imac playing wow .. i was trying it out and i can play at ultra settings with no problem. It just doesnt look that good. My 2011 imac looked better at lower settings .. also I normally run fullscreen windowed but with the 680mx the screen shrinks and the graphics get really bad .. anyone experience this?

    edit

    hmm seems to be better now .. but the fullscreen windowed doesnt work
     
  2. Mediva macrumors newbie

    Joined:
    May 6, 2012
    #2
    that would be bad, I use windowed fullscreen all the time. might give it a couple of weeks until they fix it
     
  3. Scrapula macrumors 6502

    Joined:
    May 1, 2012
    Location:
    Seattle, WA
    #3
    Haven't tried, yet. I've always hated WOW graphics. They are not high quality and you can run WOW on the crappiest of computers. I think they built it that way. My nephew plays fine with a built in Intel graphics on a MacBook. I can play on my 2009 Mac Mini without lag. Try one of the new WOW games like Pandoria and see if it is better.
     
  4. tonyep macrumors member

    Joined:
    Jul 16, 2010
    Location:
    San Francisco
    #4
    No problem running windowed fullscreen on mine. Set it to windowed first then windowed fullscreen and it will solve the problem you're having.
     
  5. Mediva macrumors newbie

    Joined:
    May 6, 2012
    #5
    Thats nice to hear...how is the general performance on native res and ultra settings? are you getting 60 fps?
     
  6. jetjaguar thread starter macrumors 68030

    jetjaguar

    Joined:
    Apr 6, 2009
    Location:
    somewhere
    #6
    thanks it worked:D
     
  7. Attip macrumors newbie

    Joined:
    Sep 26, 2010
    #7
    What kind of fps are you getting?

    I have the same gfx as you, with a 1gb fusion drive and the i7, and I'm only getting 30-40 fps on ultra - and the fps drops even further when turning the camera or flying in circles. :confused:
     

Share This Page