6G SSD not recognised in Mid2010 MacBookPro

Discussion in 'MacBook Pro' started by pco23, Mar 16, 2012.

  1. pco23 macrumors newbie

    Joined:
    Mar 16, 2012
    Location:
    Sydney
    #1
    I just purchased a Mercury Extreme Pro 6G SSD 240GB - the OWC website says this should work in a Mid2010 MacBook Pro. However - I can't get it to work. Am I doing something wrong or did I make a mistake going 6G?

    This is what I did:
    Installed the SSD in place of the internal MacBookPro HDD. Tried to start the MacBookPro. After pressing the power button, the 'welcome' tone sounds and the screen backlight comes on. I press the C key (I have a Lion installation disk in the optical drive) but there is no further activity. I do not even get the apple logo appearing on the screen. If I do the same steps with the original HDD in the machine, I get the 'welcome' tone, the screen backlight comes on, the apple logo appears after about 25 seconds and then the Mac OS Utilities menu comes up after around 9minutes.

    Model Name: MacBook Pro
    Model Identifier: MacBookPro7,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.66 GHz
    Number of Processors: 1
    Total Number of Cores: 2
    L2 Cache: 3 MB
    Memory: 8 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: MBP71.0039.B0E
    SMC Version (system): 1.62f6

    Appreciate any ideas or assistance!
     
  2. thebritishguy macrumors member

    Joined:
    Dec 30, 2011
    #2
    Try using the "option key" rather than "C"

    http://support.apple.com/kb/HT1310?viewlocale=en_US&locale=en_US

    Also, if that works, once the Lion install starts I found I had to first chose to run Disk utility, partition the new drive and then install Lion (did this 2 days ago on my old MBP)




     
  3. pco23 thread starter macrumors newbie

    Joined:
    Mar 16, 2012
    Location:
    Sydney
    #3
    Hi and thanks for your help.

    I used your suggestions (Option Key) along with this note I found on the forum: http://forums.macrumors.com/showthread.php?t=1292591&highlight=ssd+recognised

    I'm futher ahead, but something is definately flakey.

    As control tests I powered up using the option key with the HDD in place - it came to the device selection screen in a few seconds.
    I removed the HDD and with NO disk in the bay, powered up using the option key and came to the device selection screen in a few seconds.
    I put the SSD in the bay and powered up with the option key and got a grey screen - no apple logo - nothing. I waited 30 minutes (as per note above). Powered off, unplugged the SSD for 30 secs, replaced the SSD powered up again with the option key and this time go the device selection screen. I thought all was well :)
    Installed Lion from the optical bay (which included reboot) and played around for an hour or two. (Must say the performance was excellent).

    Closed the lid (is that hibernate or sleep??), came back an hour later, opened it up and only got a grey screen. Powered cycled and again only go a grey screen.

    Tried the 30 minute trick again - on the third time I got the SSD appearing in the device selection. Booted and here we are.

    There must be something wrong - either the drive is flakey or the Sata3 drive is not completely compatible with this machine.

    Anyone have similar problems? I guess I'll be RMA-ing the drive (again)
     
  4. huythanhv2 macrumors regular

    Joined:
    Apr 5, 2010
    #4
    Hmm, that is really strange. I also have a 15" MBP 2010.

    FWIW, I have an OWC 6GB SATAIII 120GB on my optibay and a HDD in the HDD bay and it is working fine.

    I'm not really sure about your problem though.
     
  5. darkmaxdevil macrumors member

    Joined:
    Aug 28, 2011
    Location:
    Bangkok, Thailand
    #5
    I don't think the problem is at the MBP or the SSD but it should be at the Lion installation disc. I would suggest you to use Lion recovery disk assistance.
     
  6. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #6
    Sounds to me like he got Lion installed, which kinda makes your answer a bit late.

    I'd ping OWC tech support. Sounds to me like a flaky drive or SATA connector. SATA III should downlevel to SATA II with no issues, so I really don't think that's the issue.
     
  7. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #7
    i was having all kinds of issues installing a clean verison of Lion on my hard drive, after some serching i found faulty RAM can give you issues.

    I put my original RAM back in and my errors during install went away

    I know this is not exactly what your saying is wrong but maybe faulty RAM can give issues in what your describing too.

    use memtest to see if your ram is faulty
     
  8. pco23 thread starter macrumors newbie

    Joined:
    Mar 16, 2012
    Location:
    Sydney
    #8
    Thanks for your suggestions and help.
    I gave up and sent the drive back. I'm going to try an OCZ SataII drive - I'll update the thread when that test is complete.
     
  9. pco23 thread starter macrumors newbie

    Joined:
    Mar 16, 2012
    Location:
    Sydney
    #9
    Well, I got the OCZ Vertex 2 (Sata2) SSD - 240GB. Installed it in the drive bay in place of the HDD and its magic. Booted from the Lion DVD it saw the new SSD, I created a partition and Lion installed. Not a problem. I now regret all the time mucking around with the OWC drive. I can only guess that either (a) the OWC drives were both faulty or (b) there is some Sata2 / Sata3 incompatibility problem (the OWC was a Sata3 drive).
    I must say, the performance is sensational - fast to boot, sleep, load apps etc and the battery life seems to be better too.
    Thanks again for all your assistance.
     

Share This Page