iPhone 6s dying at around 20%- 9.3 b1.1

Discussion in 'iOS 9' started by lovewd, Jan 19, 2016.

  1. lovewd macrumors 6502


    Aug 28, 2013
    As the title says, for the past couple of days, my iPhone 6s running iOS 9.3 beta 1.1 keeps turing off at around 20% battery life. Actually, while I was listening to music vacuuming my car on Saturday, my phone turned off all the way at 60%
    When I hit the home button, it displays the "need to charge logo" with the empty battery and the lighting cable. What should I do to fix this? Its actually kind of a pain
  2. Blujelly macrumors 65816


    Sep 2, 2012
    South East England
    I had this problem when I was doing the PB for iOS9, I got rid of the beta.

    As you would expect from a beta there will be glitches, but if you want to keep the beta then maybe a hard reset or clean install of the beta could help.
  3. Tomapple macrumors member

    Sep 9, 2014
    Santiago, Chile
    Maybe it is related to this bug: Apple Studying Issue With iPhone 6s & 6s Plus Not Updating Battery Percentage

    I have an iPhone 6S with iOS 9.3 Beta too, but luckily I haven't had this problem so far.
  4. lovewd thread starter macrumors 6502


    Aug 28, 2013
    I will try a clean install later today

    I looked into that at first, but it seems to be a separate issue from mine. And at least someone is having a good experience! I hope it continues for you! :)
  5. ColdnFrosty macrumors newbie


    Sep 27, 2012
    Similar issue here. Mostly around 12% and tremendous variation in battery drain. Some days I get less than a day of use and other times 2+ days..

  6. parrot5 macrumors 6502

    Aug 10, 2010
    Happens on a 6 too, with a bit of difference. I see the low battery warning at 20%, then jumped to 10% immediately so it showed the prompt once again, then immediately went to 1%. Stays in 1% for a minutes to hours before shutting off.
    Attempting to do my second battery calibration, but I think this all started in 9.3 beta.
  7. RicoLove macrumors newbie

    Oct 16, 2015
    I have really solid battery life on my 6 plus, but also got some wierd things, in two cycles, battery percentage goes down for 5% in one moment and just once in a cycle. But i still get same 11-12 hours of use.
  8. macgeek88 Suspended

    Jan 16, 2013
    I've had unbelievable battery life on my 6S plus, but with 9.3b1 it drains like mad, even days after install. My battery stats show nothing predictable, just Facebook using a ton but it always does but doesn't affect it like this. I love the new features but I'm seriously considering going to 9.2.1.
  9. rstark18 macrumors 6502a

    Sep 18, 2009
    I had this happen to me on the initial 9.3 install (on a 6). None of the simple trouble shooting solutions I tried would fix it. I even tried doing an Erase All Settings that did a complete erase of the phone back to factory settings. I had already confirmed that it wasn't physically my battery being bad. I ended up having to reinstall 9.2 through iTunes and then upgrading back to 9.3 and then doing a restore. That fixed it. My assumption is that something in the OS got corrupt during the initial upgrade to 9.3. The only way for me to reinstall a fresh OS was to roll back to 9.2 then 9.3.

Share This Page