6S Plus stuck in headphone mode

Discussion in 'iPhone' started by Phil A., Apr 12, 2016.

  1. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #1
    I got splashed by a wave yesterday and some of the salt water must have found its way into the headphone jack because since then my phone has been stuck in headphone mode.

    I've tried compressed air but it didn't work.

    I do have O2 insurance on it (I got it free with the phone) but they want me to send my phone off and it will take a week to get back.

    I can't be without my phone for a week so will head to an Apple Store and pay for an out of warranty repair, but is there anything else worth trying before doing that? Apart from the headphone issue, the phone is working perfectly
     
  2. DDanis60 macrumors newbie

    Joined:
    Apr 10, 2015
    #2
    This happened to mine the other day too after a small drop onto my dirt driveway. Weirdly, Ive never used the headphone jack on my last two iPhones. It was an easy fix though as I simply plugged a pair of headphones into the jack a few times. It was way too easy of a fix, but its worth a shot if you haven't already.

    Good luck!
     
  3. Phil A. thread starter Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
  4. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #4
    Try a hard reset if you haven't. Might be able to kick it out. I had a similar problem with my iPod Touch years and years ago. I had to restore it as new then restore to my backup and it worked. For whatever reason software corrupted the headphone jack sensor.
     
  5. tvbi macrumors member

    Joined:
    Jul 14, 2004
    #5
    This happened to my 6 plus last year and sucking the headphone jack 3-4 times with your mouth worked for me.
     
  6. DDanis60 macrumors newbie

    Joined:
    Apr 10, 2015

Share This Page