7 & SL file sharing: can't connect to other folders except 'Users' (Resolved)

Discussion in 'macOS' started by exFictitiouZ, Nov 13, 2009.

  1. exFictitiouZ macrumors newbie

    Joined:
    Oct 3, 2009
    #1
    I've been trying to set up file sharing between Windows 7 Home Premium and Mac OS X 10.6.2 for a while now.

    Right now, the Windows machine can connect to the Mac machine seamlessly, even editing files on it, so one side is done.

    On the other side, the Mac to Windows one, there is a little problem, and here's what I have:
    - The Windows machine successfully shows up on the sidebar in the Finder window
    - I can connect to it and it shows 'Connected as: Guest' and two folders show up: one is 'Users' which is the public shared folder automatically set up by Windows, and the other one is the one I set to share on my own
    - I can access the 'Users' folder without problem
    - When I try clicking on the other folder, a warning reads 'The operation can't be completed because the original item for "_____" can't be found' and I have no idea why this is happening when the other one is already working.

    Any idea would be very much appreciated :)
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Try clicking Connect As... then logging in with your Windows username and password. If that works, then the problem is the permissions on the second folder don't allow guests. Note that both the NTFS permissions AND the sharing permissions must allow the operations you want.
     
  3. exFictitiouZ thread starter macrumors newbie

    Joined:
    Oct 3, 2009
    #3
    resolved

    Just got it to work, and I just feel like sharing, as I've seen someone on the Apple.com discussion board posting this exact issue off-topic.

    Problem: a custom shared 'drive' on Windows 7 is inaccessible from Mac OS X Snow Leopard via guest account while a preset 'Users' folder works properly. The error message shows, 'The operation can't be completed because the original item for "_____" can't be found'

    Solution: since in a drive property, under sharing, you can't click on the button 'Share' as it's greyed out, you're only left with the 'Advanced Sharing' option. Follow these steps:
    1) Click 'Advanced Sharing' and tick 'Share this folder' checkbox and click OK. You might want to change permission level according to your preference. This is achieved by clicking on 'Permissions' button beside 'Caching'.
    2) Navigate to the 'Security' tab of the drive property, click 'Edit' and then 'Add'.
    3) Type in 'guest' without the quotation, then click 'Check Names' and OK.
    4) Adjust the permission level again to your own preference and you're done.
     
  4. JessicaD macrumors newbie

    Joined:
    Jun 3, 2009
    #4
    exFictitiouZ,

    You need to add permissions for the "Guest" user account within Windows 7. Another alternative is you can create a separate user account labeled "Mac" and assisgn permissions and rights for the folder you wish to share to that user. For additional assistance and feedback, Microsoft does have an official Windows 7 Support Forum located here http://tinyurl.com/9fhdl5 . It is supported by product specialists as well as engineers and support teams.

    Jessica
    Microsoft Windows Client Team
     
  5. goldenapple macrumors newbie

    Joined:
    Mar 3, 2010
    #5

    Ive been copying info from my PC to my MBP for 6months now cos i couldnt access the bloody thing on the network. God bless each of you ..... Amen
     

Share This Page