750m Not Working Since Sierra Update

Discussion in 'macOS Sierra (10.12)' started by SylentVyper, Oct 24, 2016.

  1. SylentVyper macrumors newbie

    Joined:
    Oct 24, 2016
    #1
    Tried looking at the first handful of pages, but didn't see anyone else with this issue. Since I've updated to Sierra, the 750m in my late 2013 Retina Macbook Pro doesn't ever kick in, even deselecting auto-switch graphics. Tried many different games, but nothing gets the 750m to kick in.

    It works perfectly in Bootcamp on Windows 10. Anyone have any suggestions?
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Please could you download and run gfxCardStatus? http://gfx.io/downloads/gfxCardStatus-2.3.zip

    You won't have to install it or anything like that. When you double-click to run it, you'll see a new icon appear in the top menu. From there you can force dGPU/iGPU. Do you get any problems when running through dGPU?

    It's worth bearing in mind that your model has a repair program for faulty graphics, so if you see issues occur after running through dGPU only, it could be a hardware problem: https://www.apple.com/uk/support/macbookpro-videoissues/
     
  3. SylentVyper thread starter macrumors newbie

    Joined:
    Oct 24, 2016
    #3
    I'll check out gfxCardStatus in a bit.

    But there are no problems with the 750m, Windows 10 through Bootcamp runs it perfectly, and it ran perfectly until Sierra was installed.
    --- Post Merged, Oct 24, 2016 ---
    So gfxCardStatus reports the 750m with no issue, but it still isn't doing anything in terms of performance. The fans never spin up when I get into a game, and it acts like it's still running on integrated graphics.

    Again, the 750m works perfectly fine on Windows 10 Bootcamp.
     
  4. Ipadlover29 macrumors 6502a

    Joined:
    May 28, 2011
    #4
    Have you tried updating to 10.12.1? I have the same laptop as you with no issues. I also have Mac os sierra and windows 10 through bootcamp.
     
  5. FNH15 macrumors regular

    Joined:
    Apr 19, 2011
    #5
    I have the same machine, on the same OS- no issues. What happens if you plug in an external display? The 750m GT should kick in then.
     
  6. SylentVyper, Oct 24, 2016
    Last edited: Oct 24, 2016

    SylentVyper thread starter macrumors newbie

    Joined:
    Oct 24, 2016
    #6
    I have it on an external display, and it shows as the 750m being in use, but when I boot up a game, or something GPU intensive, it's like it never gets out of idle clocks.

    Worked perfectly in Yosemite and El Capitan. Starting to think I need to do a clean reinstall of Sierra or something.

    Editing to add that this is NOT the Early 2013 model, I have the late 2013 model, so it wasn't part of that bunch that were bad. I've also since updated to 10.12.1 that I just found out was available, and that didn't change the behavior.
     
  7. mickeydean macrumors 6502

    Joined:
    Dec 9, 2011
  8. airlied macrumors regular

    airlied

    Joined:
    Jul 8, 2011
    #8
    I think that repair program is for early 2013 model which uses 650M, I maybe wrong
     
  9. FNH15 macrumors regular

    Joined:
    Apr 19, 2011
    #9
    I never had this issue, where the card wouldn't kick in, but I had a different issue with graphics corruption. Apple replaced the logic board under AppleCare- faulty GPU. I'm only one data point, but seeing as how similar the 750 is to the 650, I wonder if Apple won't extend the repair program to include the 750M GT as well...
     

Share This Page