iPhone 8.0.2 iMessage Bug - Have to read message 2x to remove new msg badge

Discussion in 'iOS 8' started by shenan1982, Sep 26, 2014.

  1. shenan1982 macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #1
    So I updated 2 iPhone 6 last night, and ever since updating have had this bug. When a new text or iMessage comes in, I have to open the message, close the message, and open and close it a second time to get the red "new message" badge to go away. Super annoying!
     
  2. sigp6 macrumors member

    Joined:
    Oct 7, 2011
    #2
    I have an iPhone 5s and this has happened to me intermittently since upgrading to iOS 8.0.
     
  3. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #3
    iPhone 6 with 8.0.1 and this has happened intermittently to me since iOS 8.0 as well.
     
  4. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #4
    Super annoying. All these major issues really make me question how Apple is testing the software they release. These bugs (iMessage and cell service) aren't bugs which just affect a small number of users... it's a widespread issue I don't know how Apple\testing partners miss.
     
  5. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
  6. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #6
    May have found something. I disabled iMessage on ALL of my devices at the same time (iMac\iPad\2x iPhone 6\Macbook Air), and then turned them all back on at the same time, and it seemed to clear the glitch, at least so far.
     
  7. hailhail macrumors newbie

    Joined:
    Jun 26, 2013
    #7
    I have the same problem. I tried everything...

    My message app is just ******** up!
     
  8. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #8
    2 bugs fixed, 4 more created.
     
  9. digdug1810 macrumors newbie

    digdug1810

    Joined:
    Sep 26, 2014
  10. shenan1982 thread starter macrumors 68040

    shenan1982

    Joined:
    Nov 23, 2011
    #10
    Did you see my fix that I posted earlier in the thread? Try that.
     
  11. digdug1810 macrumors newbie

    digdug1810

    Joined:
    Sep 26, 2014
    #11
    i did see that.. happened again after.. going to do a reboot though and try again in a bit

    thanks
     
  12. Dan70 macrumors regular

    Joined:
    Aug 4, 2014
    Location:
    England
    #12
    I reported this to Apple in the bug reporter centre when iOS 8 beta 5 was out and I reported this again yesterday when it started to happen.
     
  13. EM2013 macrumors 65816

    EM2013

    Joined:
    Sep 2, 2013
  14. xraydoc macrumors 604

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #14
    Haven't encountered this bug yet but iOS 7 was also full of bugs; they never should have gone to 8.0. They should have made this release a 7.5 release and focused on bugs, UI issues and performance optimization.
     
  15. Mac'nCheese macrumors 68030

    Mac'nCheese

    Joined:
    Feb 9, 2010
    #15
    I couldn't get rid of the new msg badge at all until I restarted the phone. And sometimes I can't send messages (especially group texts) at all. Something is really buggy about messages since the update.
     

Share This Page