8.1 SMS relay and call forwarding fix/issue

Discussion in 'iOS 8' started by ZEEN0j, Oct 20, 2014.

  1. ZEEN0j macrumors 65816

    ZEEN0j

    Joined:
    Sep 29, 2014
    #1
    For people not getting the code to show up on your ipad or mac. After having the same problem I noticed for the code to pop up you need to sign into your iCloud account in FaceTime and messages on all devices. Then enable both your phone number and your iCloud account mail as receivers.

    I had to do this for both sms relay and now call forwarding. On 8.0.2 all you had to do was sign into your iCloud account and just enable your phone number for iMessage and call forwarding to work. As I only want to be contacted by my phone numer on both FaceTime and iMessage and not my email. But this in no longer possible for some reason.

    Does anyone have the same problem? It doesn't matter in a way since I will still get all my messages etc.
     
  2. comics addict macrumors 6502a

    Joined:
    Feb 16, 2013
    #2
    I have it too. Had to do the same workarounds as you described.
     
  3. mookgiants macrumors member

    Joined:
    Jul 20, 2011
    #3
    are you able to send sms from your mac? I can't, keeps saying not delivered. I can receive them just fine
     
  4. childoftheko4n macrumors regular

    Joined:
    Oct 18, 2011
    #4
    This worked for me # By default i only had send/receive via my phone number on mac/ipad. Enabling my email again fixed the issue.
     
  5. Purex macrumors member

    Joined:
    Aug 22, 2013
    #5
    I notice this too. It would be great if they let us choose only the phone Number. Now its mandatory that one of the Contact its the iCloud email :(
     
  6. ZEEN0j thread starter macrumors 65816

    ZEEN0j

    Joined:
    Sep 29, 2014
    #6
    That would be great. Must be a bug.
     
  7. Bazooka-joe macrumors 68020

    Bazooka-joe

    Joined:
    Mar 12, 2012
    Location:
    Swindon, England
    #7
    I am loving this texting on my mac. Left my phone on charge in another room and sending and receiving texts on my mac. Working really well
     
  8. Arelunde macrumors 6502a

    Arelunde

    Joined:
    Jul 6, 2011
    Location:
    CA Central Coast
    #8
    IMPORTANT if you can't get the Relay codes

    After much frustration with getting Relay SMS to put a pop-up code on my iPad Air 1 from my iPhone 6+, I finally discovered the secret...

    ALL your settings in

    Messages
    Facetime
    Phone
    iCloud
    Mac (if involved)

    MUST have identical settings, ESPECIALLY the login email address to iCloud and the selected email addresses you enable to be used in any/all of the above.

    I discovered some of the above settings had my original @gmail.com iCloud ID and others had my @me.com address, which is the one I usually use. Once I logged out of those settings using the @gmail.com and logged back in using my @me.com address everything worked perfectly.

    Whew! :D
     

Share This Page