iPhone 8.4 (downloaded) Music stops playing when signal drops

Discussion in 'iOS 8' started by chinolatte, Jul 1, 2015.

  1. chinolatte macrumors newbie

    chinolatte

    Joined:
    Jul 1, 2015
    #1
    I noticed this yesterday on my commute home. Stepping into the subway music stopped playing. I thought to myself maybe I'm playing something I didn't download yet, but I went to check and I did in fact download the whole album while still at work. I go back to play and it plays another 5 seconds and stops again. This kept happening intermittently sometimes playing a couple songs in a row and other times stopping multiple times during the same song.

    Commute to work this morning same deal. It didn't stop right away when I went into the subway but during the train ride it stopped multiple times. Very annoying. I've used iTunes Match for years and this never happened with that, and didn't happen with Spotify either.

    Anyone else notice the same thing?
     
  2. chinolatte thread starter macrumors newbie

    chinolatte

    Joined:
    Jul 1, 2015
    #2
    Turning off cellular for the Music app doesn't help matters. Seems that music stops playing randomly when the data connection is spotty. Assuming that the Music app communicates with Apple servers telling them what you're listening to, but why stop playback if the connection is unavailable? This needs to be fixed.
     
  3. chinolatte thread starter macrumors newbie

    chinolatte

    Joined:
    Jul 1, 2015
    #3
    I contacted Apple Support and they were baffled. They say this is definitely not intended behavior of the app and I was the first person who they heard of with the problem. Next step is to re-flash my phone with a clean 8.4 firmware and "set up as new" and see what happens.

    I hate doing this since I'll lose everything I have but this is too annoying not to at least try.
     
  4. EdgardasB macrumors 6502a

    EdgardasB

    Joined:
    Apr 14, 2014
    Location:
    Lithuania
    #4
    Dont do that. I have restored as new and same issue for specific songs. This morning couldnt listen "Freedom". Was on WiFi but LTE also was turned on but with 1 signal bar. Turned on 3G with full bars and it started to play even though it was downloaded for offline use...
     
  5. chinolatte thread starter macrumors newbie

    chinolatte

    Joined:
    Jul 1, 2015
    #5
    So I'm not the only one with the issue. Any thoughts?
     
  6. chinolatte thread starter macrumors newbie

    chinolatte

    Joined:
    Jul 1, 2015

Share This Page