Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

8.4 Jailbreak for Mac

nafizur

macrumors regular
Original poster
Jun 11, 2012
126
45
Hi there,

i have been looking everywhere but can't seem to find it.. can someone confirm if i0s 8.4 jailbreak for mac is available or not?

thanks
 

mikecwest

macrumors 65816
Jul 7, 2013
1,046
402
Hey, how about revising the subject, so that you don't confuse people. How about a subject like "Is there an 8.4 Jailbreak for Mac?"
 
  • Like
Reactions: Applejuiced

geekguy123

macrumors member
Sep 24, 2014
55
45
I was waiting for it too but decided to go the VM route.

Parallels and Win10 went fairly smoothly. Installed iTunes and TaiG JB. Launched TaiG, said I had the wrong version of iTunes or something. Research that, found need to download and install another program to fix. Started download (I think the link on redmondpie.com is to Mega) and it got to 99% and stalled. Started it again, it finished this time. Launched program, appears to load but the progress bar stalls at the very end. Cancel it, reinstall. Same thing. Quit Parallels because of frustration. Wait a while, load Parallels back up. Restart Win10 and the program installed.

JB appears to have work on my 6+ but seems like might be several missing files? Every program I've checked can't load.
 

OutSpoken

macrumors 6502a
Jun 9, 2009
884
92
UK
I was waiting for it too but decided to go the VM route.

Parallels and Win10 went fairly smoothly. Installed iTunes and TaiG JB. Launched TaiG, said I had the wrong version of iTunes or something. Research that, found need to download and install another program to fix. Started download (I think the link on redmondpie.com is to Mega) and it got to 99% and stalled. Started it again, it finished this time. Launched program, appears to load but the progress bar stalls at the very end. Cancel it, reinstall. Same thing. Quit Parallels because of frustration. Wait a while, load Parallels back up. Restart Win10 and the program installed.

JB appears to have work on my 6+ but seems like might be several missing files? Every program I've checked can't load.
See, and thats the reason i cant be a*sed to go the VM route, looks like a lot of time and effort for jailbreaking.. I'll just stick with my working 8.1.2 JB, just would be nice to utilise some of the latest ios features like emojis, gettiing a little annoying when people send me new emojis and all i see is alien faces.

Its ironic that its Mac users that are constantly left out in the dark now with new jailbreaks.
 

thadoggfather

macrumors G5
Oct 1, 2007
12,596
10,232
Yeah 8.4 has been finnicky.

Been trying to JB for a bit now to no avail. my win10 32 bit gets hung on 40%, 64 bit win10 VM gets hung on like 30%

argh

8.3 went way smoother
 

TriJetHero

macrumors 601
Oct 13, 2010
4,954
142
World
Yeah 8.4 has been finnicky.

Been trying to JB for a bit now to no avail. my win10 32 bit gets hung on 40%, 64 bit win10 VM gets hung on like 30%

argh

8.3 went way smoother

Yep

What helped me was activating the device code and then deactivating it, also device in airplane mode and you can try to run it as administrator.

It didn't work on my XP VM
But it did work with an old windoze machine with the dreadful Vista, it immediately came back why i switched to Apple....
 

thadoggfather

macrumors G5
Oct 1, 2007
12,596
10,232
was in airplane mode, i will try admin mode later which I think I already am for my user account though

Can you elaborate on "activating device code then deactivating?"
 

Westside guy

macrumors 603
Oct 15, 2003
5,715
2,879
The soggy side of the Pacific NW
I don't think Taig ever released a Mac jailbreak.

I had no problems using a Windows 7 (32-bit) VM running in Parallels 10 on OS X 10.10.3. I was using an not-current version of iTunes (12.0.something), for whatever that's worth. The jailbreak took a lot time - sat at 20% long enough I was worried I was experiencing a bug some people had reported with an earlier version of Taig - but I just needed more patience.
 

geekguy123

macrumors member
Sep 24, 2014
55
45
Finally got my 6+ JB. Ended up restoring it yesterday morning before work and then doing the JB after work. Had to do it twice, just like my son's 5S.
 

Bako-MacAddict

macrumors 68000
Jun 7, 2012
1,830
927
California
I was waiting for it too but decided to go the VM route.

Parallels and Win10 went fairly smoothly. Installed iTunes and TaiG JB. Launched TaiG, said I had the wrong version of iTunes or something. Research that, found need to download and install another program to fix. Started download (I think the link on redmondpie.com is to Mega) and it got to 99% and stalled. Started it again, it finished this time. Launched program, appears to load but the progress bar stalls at the very end. Cancel it, reinstall. Same thing. Quit Parallels because of frustration. Wait a while, load Parallels back up. Restart Win10 and the program installed.

JB appears to have work on my 6+ but seems like might be several missing files? Every program I've checked can't load.

I would restore and re jailbreak with a windows computer. Maybe a friend with a PC? Best buy? lmao, I jailbroke with a 8 yrs old little sister's pc haha
 

The.316

macrumors 65816
Jul 14, 2010
1,334
138
25100 GR
I don't think Taig ever released a Mac jailbreak.

I had no problems using a Windows 7 (32-bit) VM running in Parallels 10 on OS X 10.10.3. I was using an not-current version of iTunes (12.0.something), for whatever that's worth. The jailbreak took a lot time - sat at 20% long enough I was worried I was experiencing a bug some people had reported with an earlier version of Taig - but I just needed more patience.

Can you explain to me how you did that? I am trying to run the Taig program on Windows 7, running Parallels 10 as well, and I keep getting an error message saying that the program cannot be run under a virtual machine.
 

mikecwest

macrumors 65816
Jul 7, 2013
1,046
402
I think you need to download a new version of Taig, there was an update to fix that. Also run the installer that installs the additional drivers.
 

Westside guy

macrumors 603
Oct 15, 2003
5,715
2,879
The soggy side of the Pacific NW
Can you explain to me how you did that? I am trying to run the Taig program on Windows 7, running Parallels 10 as well, and I keep getting an error message saying that the program cannot be run under a virtual machine.

That's an odd error - I have no explanation for it.

Here's what worked for me.

Remember to turn off Find my iPhone, disable auto lock, turn off your passcode and put your iPhone into airplane mode.

Also if your device was previously jailbroken, you need to restore it rather than just update it. And, regardless, update it from your computer via USB rather than OTA.

1) (on the Mac) back up your iPhone in iTunes, then close the program
2) (on Windows) download Taig 2.3
3) (on Windows) If you're running an antivirus program like Sophos, disable it (re-enable when you're done)
4) Plug in your phone and make sure it's on the Parallels side
5) (on Windows) launch iTunes. When you've been prompted "Trust this computer?", on your phone say yes then close iTunes.
6) (on Windows) Launch Taig 2.3
7) Unselect the second checkbox (25PP or whatever it's called), then click the jailbreak button
8) Be patient - it may take a while

If the jailbreak fails, then go back to Mac iTunes and do a fresh restore of the iPhone. When I've had problems, I've found it helpful to restore as a new device, jailbreak that, and afterward restore from backup.

With a previously jailbroken iPad, the first 8.4 jailbreak attempt failed. I restored it as a new device, then tried to jailbreak it again - the second time worked.
 
Last edited:

redbeard331

macrumors 6502a
Jul 21, 2009
803
301
I've tried everything, and every time I try to jailbreak it with taig 2.3 It says it cannot find my device, as if my phone wasn't plugged in or something.
 

pat park

macrumors 6502a
Nov 29, 2011
716
26
California
I've tried everything, and every time I try to jailbreak it with taig 2.3 It says it cannot find my device, as if my phone wasn't plugged in or something.
Restore as new device or using a previous back up? Most people report issues with back ups. If restoring as a new device most of the issues went away
 

jasko

macrumors 6502
Dec 26, 2006
471
5
with a virtual machine. I used VirtualBox and Windows 10... It was all free
I'll be doing this later today. I tried to start it last night, but ATT Uverse is slow as balls and the W10 download took forever through terminal for some reason.
 

c55

macrumors regular
May 3, 2015
164
90
I'll be doing this later today. I tried to start it last night, but ATT Uverse is slow as balls and the W10 download took forever through terminal for some reason.

I had Uverse for about 2 weeks. Now I have Charter and love it. Took about 3 minutes to download win 10 :)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.