802.11n and OSX 10.8.2 on rMBP

Discussion in 'MacBook Pro' started by tillsbury, Dec 19, 2012.

  1. tillsbury macrumors 65816

    Joined:
    Dec 24, 2007
    #1
    Hi all. This rMBP has been working fine over wifi for months. Now I reconfigure my routers so that this machine is logging in through a 802.11n router (running n-only mode). All lovely, now connects at 144Mb/s even a good distance from the router. But, when I reopen the machine from sleep the Wifi is disconnected. I have to click on the wifi symbol in the status bar, and click on the appropriate network. It then reconnects after a few seconds, and all is fine again.

    I know this isn't a massive deal, but it is a little bit annoying. Is this a known problem or something dumb I've done? Previously when I was running in non-n mode it always reconnected immediately on opening.
     
  2. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #2
    I had something similar. To fix my 2.4Ghz bluetooth interference on my rMBP, I added a second access point to my network that was 802.11n and 5Ghz only (TP-Link router), and I had exactly the problem you describe (but the terrible performance with bluetooth on was fixed!).

    In the end I replaced the TP-Link with an Airport Express, forced the 802.11n 5GHz interface to a different AP name and ordered it at the top of my known APs and everything is now solved.
     
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    If you can't figure it out you could try this:

    Move this Folder /Library/Preferences/SystemConfiguration to the desktop and restart, all Networksettings are reset, you might have to enter the Wireless Network Password again although I think it is in your keychain and is not needed.

    If this does not work you can move it back.

    Also, is your Network in Preferred Networks under the Airport tab in Network preferences?
     
  4. tillsbury thread starter macrumors 65816

    Joined:
    Dec 24, 2007
    #4
    woohoo, that's it, thanks peeps. When I switched to 802.11n it also switched from WEP to WPA2 (of course). In my network preferences the top one was my router set to WEP. I suspect that it was always re-finding the router and trying to negotiate a connection with WEP first (and failing, so disconnecting).

    Deleting that line and reinstating the network connection now defaults it to WPA/WPA2 and the connection is established before the laptop lid is fully opened.

    Thanks!
     

Share This Page