802.11n on Aluminium iMac

Discussion in 'macOS' started by -Garry-, Mar 5, 2008.

  1. -Garry- macrumors 6502a

    -Garry-

    Joined:
    Oct 23, 2005
    Location:
    Manchester, UK
    #1
    Hello.

    I just bought a Belkin 802.11n Vision wireless router. Network Utility is showing my iMac as connected to the network at 54Mb/s which suggests it's connecting over 802.11g. Is there any way to 'force' OSX (10.5) to connect using 802.11n or work out why it isn't?

    Garry
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    Are you sure the router is running in an 802.11n mode?
     
  3. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #3
    More than likely your router needs a firmware update. If the versions of n are incompatible, they will connect at the next connection they can agree on.

    TEG
     
  4. -Garry- thread starter macrumors 6502a

    -Garry-

    Joined:
    Oct 23, 2005
    Location:
    Manchester, UK
    #4
    Yep, the router is definitely running in 802.11n mode. The only option is 802.11b/g/n or "Off." The firmware is up to date as the router has only just been released

    It seems possible that the two draft n standards the equipment is using aren't compatible, but I'm fairly surprised.

    Is there anything else I can try?
     
  5. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #5
    Check your Airport settings in the Network Preference Pane, there may be something you can check in there.

    TEG
     
  6. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #6
    Network Utility will report 130 Mb/s in 802.11n mode. I noticed that you're in Ireland as well. I know that the US (FCC) has slightly different wireless specifications when compared to other nations.

    I had a Belkin 802.11n router here in the US but sadly I didn't check to see if it was working in 'n' mode.
     
  7. -Garry- thread starter macrumors 6502a

    -Garry-

    Joined:
    Oct 23, 2005
    Location:
    Manchester, UK
    #7
    I'm actually back in the UK now - just never got around to changing that.

    Anyway, for the record, a combination of Apple's AirPort update and a minor firmware upgrade on the router (.08 to .11) seems to have done the trick. I'm now seeing 802.11n
     

Share This Page