8800gt/EFI bios emulator corrupt?

Discussion in 'Mac Pro' started by bwillo, May 7, 2008.

  1. bwillo macrumors newbie

    Joined:
    Apr 2, 2008
    #1
    I have been beating my head against a wall for weeks trying to boot into Windows. So after weeks of searching for a solution and many attempts of re-installing both Windows and OSX. I am at the mercy of some of the very MAC wise folks here.

    So I will try and be as brief as I can.

    I have a first gen mac pro that has worked great since I bought it in 2006. I have bought a Gforce 8800GT 1st gen upgrade video card. Bought it the first day it shipped, like a lot of other people. I followed the the thread that pushed apple for a upgrade for us early adopters. And am glad that apple listened to their customers and made a compatible ROM for the card.

    So now to my problem and why I think it maybe a EFI issue. While waiting and reading about the then rumored video card upgrade, I tried to use a PC version of the 8800 GT, same card with a PC ROM. Well If I would of read more first I would of known that it would not work, and was really just taking a chance and thought that somewhere someone would make this work. Boy was I wrong. So after taking out the card and putting back in my 7300 stock card, I can no longer boot into windows. I get a blue screen stop error 0X000000CA (0X0000002, 0X89A0B0C0, 0X00000000, 0X00000000). Didn't turn up much searching for that error. So the symptom I have is as follows: power on holding down the option key, click on my windows disk partition on a separate NTFS formated HD, the computer try's to boot into windows, but after just a quick flash of Windows XP splash screen then straight to the blue screen. Now fast forward a week. apple releases the upgrade, took the PC cad back, ordered the MAC upgrade hopping this would fix the problem, It didn't.
    So I do a total re-install. I totaly reinstall OSX on a fresh HD, run all updates for 10.5.2. I put in another fresh drive in and run Boot camp to install a fresh copy of XP. The CD installs the startup files to RAM, then enters the setup partition/format screen. I chose new partition select NTFS full option, the HD formats. Now windows loads the install files to the hard drive and reboots. Now I am back to where I started. OSX works perfect XP will not even install new, much less boot into the old partition that is on another HD that I have pulled out right now, I also went back to the 7300, no change. I can hit F8 and get the advanced menu, if I select safe mode it freezes and goes to blue screen. If I move either of the cards to another slot I get the same result but the Mac Pro reboots in an endless cycle after a quick blue flash. In the 16x slot it just freezes on the blue screen.

    So after searching for someone with the same problem it seems I cannot find a solution other then what I have read about EFI and that it is basically emulating a BIOS so windows can boot up on the Intel hardware. So am I even thinking in the right area? Have I some how corrupted the EFI firmware? Any suggestions? I bought the Mac Pro to run Pro Tools in windows along with Windows only apps. I use final cut pro in OSX, but I spend most of my time in Windows using the awesome power of the machine. I like OSX but it is not a total OS solution for me, I really like having a hybrid, and VM's and such in OSX will not work with Pro Tools.

    Sorry for the long post, hope someone can help a fellow out:confused:

    Thanks
     
  2. waremaster macrumors 6502

    Joined:
    Aug 27, 2006
    #2
    Here is what I would do

    Try this on a different HD

    1) put the 7300 card in.
    2) boot XP in safe mode
    3) clean any drivers that are installed ie(remove all video drivers)
    4) download the latest Nvidia Beta drivers.
    5) reboot
    6) shut down and install the 8800GT
    7) install the beta drivers... Doesnt work with the official drivers so you have to use the betas
    8) reboot it will detect the 8800GT DEVICE ID 0602 card


    you should be all set then.
     
  3. bwillo thread starter macrumors newbie

    Joined:
    Apr 2, 2008
    #3
    Thanks for the response. The problem is it will not boot to safe mode, it will not allow me to install a new install of XP on a fresh drive, much less boot to my old XP partition. I have installed windows several times on this machine in the past both with boot camp and without. I really think it is a hardware issue or the EFI BIOS emulation. It had to of changed a setting in the EFI BIOS that apple will not let you mess with or re flash from everything I have read. It freezes at the exact spot described above on existing installs and new installs. Any other suggestions, I have tried the obvious ones. I have built PCs for years, but I could change some BIOS settings in that environment and probably get it to at least boot into safe mode and take out the driver then boot in full mode and install the beta drivers. :confused::confused::confused:

     
  4. waremaster macrumors 6502

    Joined:
    Aug 27, 2006
    #4
    If it were a corrupt EFI I would think the machine would not even boot OS X.

    Even still I thought the EFI was on disk 1 of the restore disks and you have to hold down some other key to get to it. For example holding D with disk 1 in starts the disk to diagnostics. You could also pull the EFI directly from apples site as well and re run that and see what happens. Very strange the problem you are having. In the past when I would run into a situation like you have it usually turned out to be the install disk.
     
  5. bwillo thread starter macrumors newbie

    Joined:
    Apr 2, 2008
    #5
    Thanks for responding. I think I am the only one in the world with this problem:(. I have searched every Mac related forum that I know of and the closet thing I could find was someone having a install problem and people were telling him to format the disk as FAT 32. But I do not want to use a third party app to format the disk because of the issues that could cause. All of my drives are WD 500 GB 16 MB buffer. I keep several of them on hand. Recording audio and video they fill up fast and when I do work for other people and they don't listen to me about buying or bringing their own external drive I just sell them a WD drive for a little more than what I paid for it. I also bought a new XP disk because they are starting to go up in price and becoming less available. So all disk are new and HD's are new.

    The one thing I forgot to put in the original post was after I put in the 8800 upgrade I tried to boot to the fresh install of OSX and I got a kernel panic. Had to instal OSX again to boot. weird:confused: I am looking for the original tiger restore disk that came with the my Mac. I have leopard in front of me along with a new XP and Vista, by the way Vista does almost the same thing after loading the install files and rebooting it just goes to the green bar going across the screen and just sits there not froze, the green bar keeps going but after hours of that I give up.

    The EFI utility on apples site says that it is only for EFI updates that did not take, and would not let you go back to a older version of EFI. So I guess at this point I have not much to lose. I will try the "D" key. Are there more startup key, power button tricks that might lend a hand? I am really in a bind here. I love this machine and hope to keep it. But if I cant run Windows I cant do everything that I need to do. I could not build a PC for the price with the power that this thing has when I bought it. Now I could build a core2 duo for what I could sell the mac for but I like OSX. Took a while to get use to it, but it is a nice OS, bugs aside. But hey coming from windows that is nothing new. But XP was more stable on this machine before this. go figure. I have been bragging about the Mac Pro since it came out. it is a work of art design wise, Just wish I would of stuck with the 7300 card and not opened this can of worms......


     
  6. waremaster macrumors 6502

    Joined:
    Aug 27, 2006
    #6

    The initial kernel panic when you put the 8800gt in might have been caused by the graphics update. Did you prep the HD for the windows install with bootcamp utility of simply boot the machine to the retail XP SP2 cd? When I did my install I did not use bootcamp for my install. I put the disk in and held down the C key and booted to the windows disk and did my format and install that way.
     
  7. bwillo thread starter macrumors newbie

    Joined:
    Apr 2, 2008
    #7
    Yes and yes. I have done it both ways. I have had my Mac Pro since they first came out in 2006, Mine was made in July. I have installed windows many times, and after a while I figured out you don't even need boot camp. So once again thank you for taking the time I am going to try the "c" key now. Will report back I always used the option key.

    Thanks

     
  8. bwillo thread starter macrumors newbie

    Joined:
    Apr 2, 2008
    #8
    Well holding down the "C" key gave me more format options, like fat 32, like loading it on a PC. why would the "C" key give me different options for the format? but anyway same result blue screen.... Debugging Code was different this time, goin fishn..... This is strange.


     
  9. bwillo thread starter macrumors newbie

    Joined:
    Apr 2, 2008
    #9
    Bump

    I am desperate here, should I suck it up and go to a retail store? will they even help me being that it is windows that will not boot/install? Apple care is expired.
     

Share This Page