iPhone 9.2 hates my wifi

Discussion in 'iOS 9' started by thedru13, Dec 15, 2015.

  1. thedru13 macrumors regular

    Joined:
    Sep 12, 2014
    #1
    So I think this has been an issue with ios9 in general but i have not been effected till now. iphone 6S+ updated to ios9.2 and my home wifi has been terrible. I used to have wifi calling and now I don't anymore and now My backups won't run, my email is hanging, and surfing the web is painful. If i switch to my data connection all if fine. I have tried to trouble shoot a few things as far as deleting and re-adding my wifi connection. Reset network connections reboots and also even trying to change my DNS on my phone and router. Nothing seems to improve it. Anyone have similar issues and have any sort of resolution?
     
  2. sbailey4 macrumors 68030

    sbailey4

    Joined:
    Dec 5, 2011
    Location:
    USA
    #2
    I would look for a firmware update for your router. Also if you are in a suburban area with lots of other wifi networks try manually selecting a channel (1,6, or 11 preferably) verses the Auto setting. You can use an app called inssider on your PC to see what channels are busy near you. Sounds like more of a wifi issue than iOS issue to me. Also a simple reboot of the router will sometimes solve this type of issue. (even if other devices seem to work fine).
     
  3. thedru13 thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #3
    Thanks sbailey4.. Did all that. updated the firmware, tried different channels rebooted the router ect. Other devices on my WAN are not having issues Just my Iphone so it leads me to believe its ios related.
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Yep, further to the above I'd also ensure your router wireless encryption is on WPA2-PSK (may be called WPA2-AES) only -- don't do 'WPA Auto' or WPA2/WPA mixed.

    That might do the trick.
     
  5. thedru13 thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #5
    Thanks. I am pretty sure things are solid on the home networking front. Wife is a security engineer aka blackhat so network stuff is on point.. So trust me things are covered at home LOL...
     
  6. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #6
    I updated both a 6S+ and Mini 3 to 9.2 and ran into a wifi issue:

    • Have wifi as 2.4ghz / 5ghz as separate id's. They both are having difficulty staying on 5ghz. Keeps dropping it and switching to the 2.4.
    Just these two devices. Other iDevices on 9.1 and earlier are good along with a host of others.
    Running TWC 200/20.
     
  7. jetsam macrumors 6502

    Joined:
    Jul 28, 2015
    #7
    Some things I would try (you may already have done all of these things):

    1) Turn off router security, just to see if that fixes the issue
    2) On the router, reserve a new IP address for the iPhone
    3) Are you using IPv6? If so, turn it off at the router, and see if that helps.
     
  8. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #8
    Some questions: Is your iPhone wifi OK on other routers (I assume so but gotta ask)? Have you set up your iPhone as new (no restore or apps) and reproduced the issue with default settings? What does speedtest.net show? Probably something pretty dismal.
     
  9. Sicapo macrumors newbie

    Joined:
    Mar 16, 2015
    #9
    Had a similar problem as my Iphone 5s (latest iOS) would lose internet connectivity although it was still connected to my wifi. Turned out to be a problem with the dhcp lease renewal. Set a static ip address on my iphone (and reserved it in the dhcp) and problem went away. My wife's iphone is on the same iOS and she doesn't have this problem.
     
  10. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #10
    I did a bit of testing yesterday with a 6S+ and Mini3 on 9.2, a 6+ on 9.1 and a Note 5 on Android 5.1.1.
    I hooked all four devices to the 5ghz band and performed random activities that required internet data.
    • The 6S+ dropped from the 5 to the 2.4 after 15 minutes
      • A reconnect to the 5 had it dropping back to the 2.4 after 30 minutes
    • The Mini3 dropped from the 5 to 2.4 after approximately an hour
      • A reconnect to the 5 had it dropping back to the 2.4 after 20 minutes
    • The 6+ dropped from the 5 to 2.4 after approximately an hour - after the Mini 3 dropped
      • A reconnect to the 5 had the device still on the 5 when testing stopped
    • The Note 5 was still on the 5 ghz band after 2 hours when I ceased my test
    It looks like there is an issue with iDevices especially on iOS 9.2 holding the 5ghz wifi band and supports my initial observation that my iDevices are having issues. For me.
     
  11. Jaggrey macrumors regular

    Jaggrey

    Joined:
    Sep 7, 2015
    Location:
    Pembroke Pines, FL
    #11
    I've been having weird issues with my phone on wifi ever since the update as well. I thought I was crazy or just being impatient but I'm so glad I found this thread.
     
  12. Yun0 Suspended

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #12
    0 problems with all the ios devices in this house for years with ddwrt on my router..

    consider removing that garbage that is stock firmware, if u have a supported router. before the "i shouldnt have to flash my router to..etc" is said, it doesnt mean something else can never be the cause of another device's problems..stock firmware on many routers sucks for everything connecting to them
     
  13. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #13
    My Idevices ipad 2, 5s and 6s all hold the ssid on 5ghz. I have two guest networks and the issue for me is they can't hold the password after switching from guest to non-guest and back. Seems it's been that way since iOS 8, was hoping iOS 9 cured that.
     
  14. Elisha macrumors 6502a

    Elisha

    Joined:
    Nov 21, 2006
    #14
    That's nothing to so with your devices. Your router probably has a feature like Smart Connect enabled which automatically switches connected devices to 2.4Ghz or 5Ghz based on channel interference and connection speed.
    Also the further away you are, the more battery your device uses while maintaining a 5Ghz connection, so it probably also prefers a stronger connection which would be the 2.4Ghz since 5Ghz can't maintain range when going trough walls and ceilings like the 2.4Ghz can.
    So unless iOS allows you to set a preference for preferred Band, it will automatically choose the one that requires the least transmit power and if your router has Smart Connect or whatever your router manufacturer calls it, the router will decide the strongest, fastest, interference free band and channel.
     
  15. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #15
    Sorry, but no.
    Prior to iOS9 I had no issues with any idevices that can utilize the 5ghz band holding it. This also holds true that my other wifi devices that support the 5ghz band have no issues.
    Now, the issue only exists for the iDevices in my household that are running iOS9.x Seems really really strange that it only affects these devices and only on this specific OS version. Let's call it what it is; an iOS9 problem.

    btw: my router is located in the room next door to my home office. One interior wall and about 6 feet straight line.
     
  16. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #16
    If it were iOS 9.2 the issue would be endemic. I have a netgear r8000 with no issues hanging on to 5ghz on 5 Idevices. It's something with your router and iOS 9.
     
  17. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #17
    Not disagreeing with you as only iOS9 devices are affected. However, it is an iOS9 issue.

    Arris DG1670 unit supplied by TWC
     
  18. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #18
    Saw this on an Amazon review for that modem, reviews as a wireless router were not favorable but reviews for the modem were:
    1. Turn off the 5ghz line and remove all options for the 5ghz.
    2. Set the router to n only
    3. Enable wmm and ap isolation
    4. Turn off the firewall
     
  19. Elisha macrumors 6502a

    Elisha

    Joined:
    Nov 21, 2006
    #19
    First of all, modem/router combination devices are pain in the ass and most likely fw limited feature wise. I used to work for a Telco and they introduced one that let you port forward and save but the fw itself locked out the feature so half the selectable settings were useless.
    If you want all your devices to stay on 5Ghz, set up different SSID names for both bands and make your devices forget all the network settings and reconnect only to the 5Ghz SSID.
     
  20. Rhonindk macrumors 68020

    Rhonindk

    Joined:
    Oct 3, 2014
    Location:
    Bloom County: Meadow Party
    #20
    From both - thanks for the information. This combo is unfortunately one supplied by Time Warner as part of my "Whole Home" package and I can only minimally affect the settings.

    Aside from that, this was just to show that I now have 5ghz issues with those devices on iOS9 where I had none before and still have no issues with non-iOS9 devices.
     
  21. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    What Exit?/Saguaro Country
    #21
    I said above I have a netgear r8000. One of the firmware fixes, and I don't remember when I installed it, but the release notes had a specific mention of IOS devices. It sounds like some wifi behavior was changed in 9.2 somewhere, but it does not seem to affect all users and seems somewhat based on the router. Unfortunate this is happening to you in this case and maybe 9.2.1 will fix whatever was changed that is causing these dropouts.
     
  22. djshack macrumors regular

    Joined:
    Apr 11, 2010
    Location:
    Somerville, MA
    #22
    FWIW, I've been having wifi issues too on iPhone and iPad since upgrading to iOS 9.2. I admittedly haven't put a lot of effort into figuring out what's causing them however, but hopefully a fix will be released to address this.
     
  23. brentsg macrumors 68040

    Joined:
    Oct 15, 2008
    #23
    Well 9.2 hates my WiFi too, and it's via Apple's latest Airport Extreme. Both my kids iPad 2's are spamming us to enter the WiFi password every few minutes. I've had it happen a few times on the iPad Pro as well, but I finally just set that to LTE so I could be done with it. It really, really sucks since the kids are off for Christmas and I'm working from home.
     
  24. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #24
    Have you tried resetting network settings on the devices, or maybe just "forgetting" the network on both iPads would do it.
     
  25. brentsg macrumors 68040

    Joined:
    Oct 15, 2008
    #25
    Tried both, unfortunately. It's got to be a software glitch. It asks for a password, you enter it... like a 5 second pause and it'll ask again.

    I forget my exact release numbers, but it definitely coincides with the update to 9.2. It was happening on a previous release, was fixed by a release, then was reintroduced.
     

Share This Page