a big iCloud email glitch?

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by satirev, Jan 1, 2014.

  1. satirev, Jan 1, 2014
    Last edited: Jan 1, 2014

    satirev macrumors 6502

    Joined:
    May 23, 2010
    #1
    I recently set up an iCloud email, and I set it up with the mavericks OS mail app.

    I right clicked on a message that was in my inbox and i went to move to --> inbox --> iCloud and then the message vanished.

    I can't find it in any folders, can't find it in search, can't find it in the web client, what happened to it??

    any help is appreciated...thanks
     
  2. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #2
    just tried rebuilding my mailbox and that did not bring the emails back. Seems like this is a pretty big bug, surprised that this hasn't been addressed yet..
     
  3. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #3
    interesting, 250 reads and not a single comment, this is a major bug that should be on the front of macrumors right now.
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    I have not run in to a bug like this.

    To be clear... you tried to move it from the inbox of what mail account to what folder(on what account)? Inbox->iCloud sounds like you tried to move it from the inbox to the inbox.
     
  5. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #5
    yes, if you attempt to move an email from the folder its in into the same exact folder the email completely vanishes.
     
  6. Bear, Jan 1, 2014
    Last edited: Jan 1, 2014

    Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #6
    Why did you even try to move the mail to the same box it was in? And is it an iCloud bug or a Mail.app bug or some other mail program? What version of OS X?
     
  7. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #7
    it was obviously a mistake haha.

    mavericks. native mail app.
     
  8. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #8

    that being said though, i don't think a mistake of moving mail into the same folder its already in should cause the mail to be permanently deleted/vanish into cyber space never to be seen again
     
  9. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #9
    10.9.0 or 10.9.1?

    I agree, but is it an iCloud issue or a Maill.app issue.
     
  10. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #10
    Have you tried the vacuum trick on Mail's Envelope database? This is similar to rebuilding the database, but doesn't delete anything - instead, it cleans out stale entries that accumulate in there. If I remember correctly, you need to use the Terminal for this, point the sqlite command at the offending database, then type "vacuum" (without the "quotes") at the sqlite> prompt.
     
  11. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #11
    10.9.1 -- i think its an iCloud issue because the emails are also gone on the web side.

    i haven't tried this yet, will report back, thanks
     
  12. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #12
    I can confirm the behavior - I've lost a couple of emails this way. Do I think it is front-page headline news, no.

    A.
     
  13. satirev thread starter macrumors 6502

    Joined:
    May 23, 2010
    #13
    just the fact that someone could potentially lose all of their emails trying to move folder to folder and accidentally clicking the same folder should make this front page news....i can't believe this glitch even exists...
     
  14. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #14
    It might be, but it might not be. It would need to be tested with a different mail client to confirm where the bug is.
     
  15. exi macrumors 6502

    Joined:
    Oct 16, 2012
    #15
    Just to throw it out there, as it was mentioned in a separate thread of mine: I saw this same behavior while moving messages within Mail 7.1 / OS X 10.9.1 while working with a Gmail account, not iCloud mail. Not consistently, but I definitely had a few messages vanish on me.
     

Share This Page