A cornucopia of pain and frustration.

Discussion in 'PowerPC Macs' started by shhornbe1316, Feb 8, 2011.

  1. shhornbe1316 macrumors newbie

    Feb 8, 2011
    A friend mailed a PPC Power Mac G5 to me. The package was too heavy and was dropped in transit somewhere along the line. The handles on the corners took the brunt of the fall, bending inward. I peaked inside but didn't see any obvious problems.

    I start the machine and it chimes and boots to the flashing question mark folder. I checked the connectors to the HDD and tried again with no success. Resetting the PRAM did not help, so I put in the proper installation disk and held "c" while it booted up. The pin wheel showed up for a second before the screen darkened and demanded I restart by holding the power button. I figured this to be some sort of kernel panic. At that point the fans begin to whirl up faster and faster until they had to have been at top speed.

    I've tried holding the shift button and "x" on boots with no success.

    I would have no problem reinstalling OS X because there is nothing on the drives I don't mind losing. I'm just at a loss at how to do this. I don't have another computer in the house with firewire.

    If nothing else this is a tragic story for you all to keep in the back of your minds when shipping computers, but, if someone has any advice or help I'd appreciate it.
  2. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    You're sure it's the correct install disc? You might want to try and grab a retail version of 10.5 and use that. You're correct that it's kernel panicking. Unfortunately without a drive to write to, you're not going to get a panic log.

    One test, restart and hold down Option key. You should get a screen with all bootable volumes (e.g., volumes that have bootable OS on them.). If that fails, then it's likely a logic board (or some other hardware) problem.
  3. shhornbe1316 thread starter macrumors newbie

    Feb 8, 2011
    Thank you for the reply!

    I double-checked the HDD connectors and found one that was a bit loose still, so I pushed it in and rebooted. Thankfully it started up properly.

    Thanks again for your help!

Share This Page