Resolved A disk read error occured Press Ctrl+Alt+Del to restart

Discussion in 'Windows, Linux & Others on the Mac' started by klimos, Jun 6, 2017.

  1. klimos, Jun 6, 2017
    Last edited: Jun 6, 2017

    klimos macrumors newbie

    Joined:
    Feb 9, 2010
    #1
    I'm not sure where to put it. The error is typical for Windows, but I haven't booted it for a month or so.

    I have MacBook Pro 13" mid-2012 (last non-retina). The only difference to a tock configuration is SSD drive Crucial MX300 525GB that I installed over half-year ago. I also have 2 operating systems installed (each one on it's own partition): macOS Sierra and Windows 10 Pro using Bootcamp.

    Today, like every morning, I put my MacBook to sleep (running macOS), put it to my backback and took it out after I arrived at work. I didn't notice a macOS user password entry screen, instead there was a black screen with:
    "A disk read error occured Press Ctrl+Alt+Del to restart"
    I suspect, the laptop rebooted by itself, because I'm sure I didn't switched it off and I didn't touch the power button.

    Ctrl+Alt+Del of course doesn't work, so I had to do hard reset. If I don't touch anything after reboot, any OS doesn't load, I'm getting the same error. And now, most interesting: when I hold the option key to access boot menu, every time I'm getting different combinations of systems to boot into. In approximately 50% of the cases it is as expected: "Macintosh HD" and "Windows", but randomly I'm getting also:
    - "Macintosh HD" only
    - "Windows" only
    - "EFI Boot" and "Windows"
    - nothing (only WiFi selection dropdown)
    - "Macintosh HD" and "Macintosh HD" (the same, but twice)

    Whatever I choose, I am always getting an error mentioned in the thread title. If it matters, I noticed that couple of times, when I didn't select anything for a while (about a minute), all the disks disappeared and only WiFi selection remained.

    EDIT:
    I just noticed that my post contains only description of the problem and no question asked. Did anyone encounter a similar issue on a recent OS? I found something similar already, but all problems were related to old Mac OS X (like Lion) and Windows 7 (or even XP). Nothing new for Sierra/Win10 combination.
     
  2. klimos thread starter macrumors newbie

    Joined:
    Feb 9, 2010
    #2
    The issue has been solved, but I don't have any good news to anybody who has the similar problem.

    First of all, after not receiving any suggestions here and on other forums, I decided to remove all my partitions and set up the system from scratches. I already failed on creating new partitions in recovery mode. It couldn't have been done, as I was receiving different errors in Disk Utility. Then I decided to send my MacBook to professionals and diagnosis was: faulty hard drive with 99 CRC errors. It was Crucial MX300 525GB and I just bought few months ago during Black Friday sales. When I contacted the seller (Amazon) they sent me a new one and they didn't even want the old one back. After swapping SSDs everything is back to normal.
     

Share This Page