A faulty battery? Unibody MBP

Discussion in 'MacBook Pro' started by yatz, Jan 5, 2009.

  1. yatz macrumors newbie

    Joined:
    Oct 30, 2008
    #1
    Hi,

    I am a first time Mac user and purchased the new MBP 2.53Ghz in October when they were released. All has been going well, the OS is very easy to learn and intuitive. However, I now have a problem with the battery. It indicates that it is 100% charged and no matter how much I use the notebook it doesnt change!

    - Applecare telephone support suggested a SMC reset which did not work.
    - I have tried draining the battery but it still displays 100% in the menu bar and also the 8 LEDs for the battery check. As it thinks it is fully charged, when plugged into the power adapter it will not charge anymore.
    - I boot from the Mac OS X install DVD and try to click on the battery indicator on the menu bar but it does not respond to my click, the other menu options (Airport etc) do !!
    - I tried a reinstall of Mac OS X thinking it may be a software issue but this has not worked either. I am running 10.5.6, everything works fine apart from the battery.
    - In the System Profiler under 'Power', these are the readings (pretty spectacular !!)

    Battery Information:

    Model Information:
    Serial Number: SMP-bq20z951-3934-65f
    Manufacturer: SMP
    Device name: bq20z951
    Pack Lot Code: 0000
    PCB Lot Code: 0000
    Firmware Version: 002a
    Hardware Revision: 000a
    Cell Revision: 0100
    Charge Information:
    Charge remaining (mAh): 65377 <---- ALARM BELLS :eek:
    Fully charged: Yes
    Charging: No
    Full charge capacity (mAh): 65377 <---- ALARM BELLS :eek:
    Health Information:
    Cycle count: 57
    Condition: Good <----- :confused:
    Battery Installed: Yes
    Amperage (mA): -1
    Voltage (mV): 9398

    Any suggestions will be much appreciated, I have booked an appointment with the Genius bar for Tuesday, hopefully a battery replacement will do the trick !!

    Cheers

    Yatz
     
  2. gjw4u macrumors 6502

    Joined:
    Dec 2, 2008
    Location:
    Switzerland
    #2
    Call Applecare again or bring the MBP into an Apple Store, so that you can get this issue sorted out under warrenty.
     
  3. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #3
    The microchip inside the battery that measures the remaning charge is damaged, Apple will replace the battery for you if it is less than a year old, simply take it to your local Apple store and show it to the Geniuses behind the Genius bar, you will get a new battery on the spot.
     
  4. hishat macrumors regular

    hishat

    Joined:
    Oct 14, 2007
    Location:
    United Kingdom
    #4
    I second that, something similar happened to me but instead was displaying 0%. They will replace it for you usually on the spot. Just walk in with a friendly smile and you'll be surprised how far that takes you.
     
  5. yatz thread starter macrumors newbie

    Joined:
    Oct 30, 2008
    #5
    Hi

    Thanks to everyone who posted a reply!

    I went to the Apple Store in Leicester today and the Mac Genius swapped the battery for a new one, everything seems to be fine now, calibrating the battery as we speak.

    Cheers

    Yatz
     

Share This Page