A few keys not working...

Discussion in 'Mac Accessories' started by chopchop, Apr 24, 2011.

  1. chopchop macrumors newbie

    Joined:
    Mar 27, 2011
    #1
    Hi -

    I posted this about a month ago in the iMac forum and it hasn't been resolved. Someone suggested I move it over to this forum - so here goes.

    My right shift key, arrow up key, and the 4, 5, and 6 keys on the number pad are all not working. Nothing has spilled.

    I've plugged in a different keyboard - same problem. Zapped pram - problem remains. Trashed prefs, restarted, repaired disk permissions, mouse keys off, checked international settings, speech setting off - everything I could find online - nothing has worked. The keyboard viewer is showing that the keys are not being seen.

    Two things have changed since I originally posted this in the iMac forum. I upgraded from 10.4 to 10.6 (finally), but the problem remains.

    I've also tried out my wireless keyboard that I use with my laptop. Strangely - the wireless works fine.

    Anybody have any thoughts? Why would TWO usb connected keyboards have the exact same issues, and the wireless work fine?

    I'm fine with just buying a new keyboard - but I'm concerned that the same problem will happen with a new one.

    Any thoughts are welcome.

    Thank you!
     
  2. carlgo macrumors 68000

    Joined:
    Dec 29, 2006
    #2
    Something under the keys, some sort of crud, a hair maybe? This can happen even without spilling liquid on it. Try cleaning under one and see. I've done this a couple of times successfully. I suggest researching how to remove and replace the keys on your unit properly.
     
  3. chopchop thread starter macrumors newbie

    Joined:
    Mar 27, 2011
    #3
    Thanks Carlgo -

    I should have mentioned that I tried cleaning too - before I tried a different keyboard.

    Thanks again though!
     
  4. Washac macrumors 68020

    Washac

    Joined:
    Jul 2, 2006
    #4
    Hi

    Not highjacking your thread but I have a similar problem with a keyboard here.

    Does not matter what wired keyboard I plug into my Mac Pro ( I have a couple ) the brightness keys (F1 &F2) do not work.

    The keyboards and everything else (monitors) all work fine in other combinations, it is just the Mac Pro, have not tried a wireless keyboard, I have one somewhere, will give it a try.

    Now you have posted this I see this as a USB circuit issue.
     

Share This Page