A few problems with my Macbook Pro

Discussion in 'MacBook Pro' started by amalkan, Sep 23, 2015.

  1. amalkan macrumors newbie

    Joined:
    Jun 16, 2015
    #1
    So, I'm running.

    2015 Retina Macbook Pro 13' 16 GB 1867 MHz DDR3 2.7 GHz Intel Core i5

    Yosemite 10.10.5

    My problems so far are:

    I'd say at-least once a week my wifi just turns it self "off" and I cannot turn it back on by just hitting the button. The regular fix is a restart.

    Also, my ports sometimes don't immediately wake, or wake at all once coming out of sleep.

    Thanks in advance!
     
  2. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #2
    First, run a diagnostics test. If nothing comes up, make an appointment at the Genius Bar to have them check it out.
     
  3. d0hv macrumors regular

    d0hv

    Joined:
    Sep 3, 2015
    #3
    "I'd say at-least once a week my wifi just turns it self "off" and I cannot turn it back on by just hitting the button. The regular fix is a restart."

    My 2015 rMBP 13" that I bought about 3 weeks ago does the exact same thing every once in a while. It happened twice maybe. It's no big deal to me because I probably won't be keeping this Mac for a year. When the next redesigned MacBook Pro's with the Skylake processor or whatever it's called are announced, I plan on selling this one and getting a 15 inch. Hopefully its available in gold.
     
  4. Alameda macrumors 6502a

    Alameda

    Joined:
    Jun 22, 2012
    #4
    What's the button that you're referring to?
     
  5. amalkan thread starter macrumors newbie

    Joined:
    Jun 16, 2015
    #5
    Not button, but when you go into network preferences, you can click on "turn wi fi on" but it doesn't work.
     
  6. Alameda macrumors 6502a

    Alameda

    Joined:
    Jun 22, 2012
    #6
    I think that happened to me today, too
     
  7. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #7
    I'd call apple on this, it could very well be a hardware issue.
     
  8. Falcon9 macrumors member

    Falcon9

    Joined:
    Jun 17, 2015
    Location:
    Eastern Canada
    #8
    I've never had issue with any of my ports on my 2015 13" rMBP (but for the amount I use my ports, I could have gotten away with getting the 12" MB instead...), but I've experienced the wifi issue you describe before (not on a weekly bases though).
     
  9. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #9
    You have a warranty, make use of it.
     

Share This Page