A little concern about my MagSafe light

Discussion in 'MacBook' started by arrfenwoof, Dec 13, 2013.

  1. arrfenwoof macrumors member

    Joined:
    Nov 7, 2013
    Location:
    Augusta, Maine, USA
    #1
    Right, so when I plug in my MagSafe, it's green like it should be. But after an undetermined amount of time the light will get so incredibly DIM that I have to put my eye up to the light to see it. The computer still charges and powers on just fine, I assume it's just the OCD in me with the cosmetic part of it. Is there anything I should look out for... Is this a sign that I might have a logicboard, dc board or charger failure soon? Thanks and sorry for being paranoid!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    It's not likely that the dim light is a sign of charger failure, and it's definitely not a sign of logic board failure. As long as it's charging properly, I wouldn't worry about it. If the charger fails, buy a new one. Until then, enjoy your Mac and try not to worry.

    The link below should answer most, if not all, of your battery/charging questions. If you haven't already done so, I highly recommend you take the time to read it.
     
  3. JeffiJers macrumors 6502a

    Joined:
    Sep 12, 2012
    Location:
    U.S.
    #3
    I actually have this same issue with a new thunderbolt display...

    When i plug it in initially the LED is barely lit, then in a few minutes it brightens.
     
  4. arrfenwoof thread starter macrumors member

    Joined:
    Nov 7, 2013
    Location:
    Augusta, Maine, USA
    #4
    Hmm, i'm not sure. I did just find this out though. When I first connect the charger, it's bright green like it should be. If I even BARELY touch the charger plug, it dims to almost nothing, although no matter how much I wiggle or nudge the plug, it never stops showing that it's plugged in, so I assume thats good. Kinda weird however.
     
  5. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #5
    Mine does that from time to time, its the L shaped one that replaced my failed T style one on my '08 (60W). It's always worked though, so I just don't worry about it. Sometimes it does it when it's plugged in facing the other way, other times it's bright as usual. :rolleyes:
     
  6. arrfenwoof thread starter macrumors member

    Joined:
    Nov 7, 2013
    Location:
    Augusta, Maine, USA
    #6
    Ah, right then. Must be me just being overly cautious. Just wanted to make sure it wasn't going to hurt my MacBook to use it like it is. It's the T-style plug but still charges and powers it just fine. It may be a mid-2007 MacBook but after putting 4GB ram and 320GB hdd into it, i'm absolutely in love with it and want to keep it around for as long as I can.
     

Share This Page