A Little Help With Web Site

Discussion in 'Mac Basics and Help' started by raf66, Jan 5, 2009.

  1. raf66 macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Columbus, Ohio
    #1
    Merry Christmas and Happy New Year to everyone. A recent "switcher" and Mac newbie here.

    I just purchased a new iMac 20" with 2.66 mhz and 320G hard drive a few days ago and I couldn't be happier. I've been a Windows user my entire computer life and it feels good to make the switch. What a great machine!

    One question I have for the group is why can I not get into youtube.com from Firefox? It takes me to the UK youtube.com site and I've tried several different ways to get into it, both directly and indirectly. The thing is, it works fine when I try to get into it through Safari.

    Any ideas?

    Thank you.
     
  2. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #2
    If you live in the UK then you'll get send to the UK youtube by default, if you dont live in the UK then something is wrong, but you can fix it simply:

    Go to youtube in Firefox
    In the top left you'll see the Youtube Logo, and just below in Blue "UK | English"
    Press the "UK" then a menu will appear
    Then press where you live
    voila!

    :)
     
  3. raf66 thread starter macrumors regular

    Joined:
    Nov 29, 2008
    Location:
    Columbus, Ohio
    #3
    kastenbrust,

    Thanks for the info. I tried that before posting. However, I do have some good news. No, I didn't switch to that low-cost insurance carrier. (Sorry, couldn't pass that one up). I cleared the cache and the private data (including cookies), quit Firefox, then restarted it and it worked.

    Woohoo! My first tinkering with my iMac and it worked and nothing seems to be on fire.
     
  4. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #4
    Count yourself among the lucky few.
     

Share This Page