A lodged DVD

Discussion in 'Mac Pro' started by ant03, Jul 4, 2006.

  1. ant03 macrumors newbie

    Jul 4, 2006
    new zealand
    Hey im a new member here, and i hav a DVD that is lodged in the optical drive in my G5 which does not seem to eject.

    I was wandering if anyone can help.
  2. benthewraith macrumors 68040


    May 27, 2006
    Miami, FL
    There are many ways young padawan. Try taking a blunt butter knife, stick in in the cd hole, and push the DVD down by pushing the handle up. But be very careful. (note, this has worked before so....)

    And no, it isn't supposed to be sarcasm. There are a few other ways, one of which includes taking it to the Apple Store.
  3. FullmetalZ26 macrumors regular

    Jun 12, 2006
    Have you already tried the usual eject options such as the Disk Utility, holding mouse button down on startup, or ejecting from Open Firmware? Whenever I end up with a disc that won't eject, Open Firmware always seems to take care of it without a problem.
  4. WildCowboy Administrator/Editor


    Staff Member

    Jan 20, 2005
    Sticking a butter knife (or anything else) in the drive should be a last resort if your computer is out of warranty. It might work, but it's also a great way to completely bork your drive.FullmetalZ26 gave some good suggestions. Also, you might want to try shaking the computer a bit to see if you can jostle the disc free. Be gentle, and make sure the computer's off when you do it.

    I would recommend visiting an Apple Store if you have one nearby and asking a Genius what they would recommend. They might tell you to just bring it in and they'll take care of it. They may or may not charge you for it, but even if they do, it might be worth it.
  5. ant03 thread starter macrumors newbie

    Jul 4, 2006
    new zealand
    for the knife thing. shuld i shutdown the computer first?
  6. cleanup macrumors 68030


    Jun 26, 2005
    Umm before stabbing your computer, restart it, and upon startup hold down the left click mouse button. DVD should come out, unless it's physically lodged. If it's just the Finder/optical drive doesn't recognize it and it won't mount on the desktop therefore when you press Eject nothing happens, then try the left-click thing... before... stabbing your iMac.
  7. ant03 thread starter macrumors newbie

    Jul 4, 2006
    new zealand
    I have tried that, but i think its physically lodged in.
    the DVD plays perfectly in the Drive but it just wont come out, and it makes some sort of noise when the disc tries to eject.
  8. tdhurst macrumors 601


    Dec 27, 2003
    Phoenix, AZ
    Okay, whoa...

    All right, if the DVD PLAYS perfectly something is wrong with the eject mechanism on the drive itself, so the only thing you'll get with the butter knife idea is an already broken DVD drive AND a scratched DVD.

    Either take the drive out and take it apart or drop your computer off at a service center.

Share This Page