A lot of emails lost after each upgrade!!!

Discussion in 'OS X El Capitan (10.11)' started by arcureo, Oct 23, 2015.

  1. arcureo macrumors newbie

    Joined:
    Jun 26, 2009
    Location:
    Padua - Italy
    #1
    Hi, I noticed that after I upgraded to El Capitan my Mail program showed practically NO mail messages in the "inbox" folder.
    I gave the "rebuild" command and it seemed to fix the problem.
    Now I'm noticing that it's NOT fixed AT ALL.
    A few weeks ago I received an email that I intended to answer back in a few days. Then I did the latest upgrade to 10.11.1 (just a coupla days ago)
    Today I decided it was time to answer that email... guess what?? NOWHERE TO BE FOUND!!!
    I did also a search with Spotlight... NO RESULTS! Not even in a remote folder. As it never existed!!!
    That's a SERIOUS issue. I asked the sender to mail me back the stuff again, but you can see this is a MAJOR flaw.

    Any suggestions?

    A'
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Use IMAP, then the email always exists on a mail server and not just on your machine. Or restore it from your backup (TM, CCC or similar).
     
  3. arcureo thread starter macrumors newbie

    Joined:
    Jun 26, 2009
    Location:
    Padua - Italy
    #3
    Ok, but the serious flaw still stands. It's not conceivable that after every upgrade my mailbox goes bananas!!!
     
  4. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #4
    Well. Better solution is keeping a copy of your mails on server.
    Sometimes I receive a notification saying MacRumors have new posts or something. But when I check it in Apple mail, it disappears. Yeah, as you say, like this mail does not even exist.
    For POP, well, do frequent regular backup of your mail and keep them in at least two different locations.
    Uh, all are my thoughts.
     
  5. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #5
    Lots of things can lead to the loss of your data if your only copy is on your machine and it isn't backed up.
    I have upgraded two machines to EC and not had any inbox or emai issues but I don't use Mail, I use IMAP so copies are held on the server and I have multiple backups hence no need to blame anyone for data loss.

    Are there any widespread reports of inboxes being lost during the upgrade?
     
  6. arcureo thread starter macrumors newbie

    Joined:
    Jun 26, 2009
    Location:
    Padua - Italy
    #6
    Well, I did retrieve it using Time Machine, after all, yes... but it's the first time in years that an OS upgrade gave me such problems. And such specific ones. I can understand old apps/programs that don't work after a big upgrade, ok, that's understandable... but this? I never lost emails all of a sudden and only after a very precise event (the upgrade, that is).
    This spells "bug", in my opinion.
     
  7. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #7


    So leave feedback for Apple, that will be the best way to report it.
     

Share This Page