A lot of kernel problems

Discussion in 'Buying Tips and Advice' started by Munniemunnie, Sep 24, 2016.

  1. Munniemunnie macrumors newbie

    Joined:
    Feb 24, 2013
    #1
    Hi people,

    Ive got a major problem and i hope someone can help me out. I had el capitan installed and after a while my chrome browser kept crashing with the saying it cannot load the page. And this weird behavior was also companied with sudden shutdowns which is known the kernel panic. Well, after a while this two problems became unbareable so i decided to format my drive and install mavericks through usb. That didnt help at all. Both strange behaviors i mentioned kept coming and even more. Its almost impossible to browse the internet without crashing. And now my mac has also troubles with installing new apps. It always says its broken or something. If i want to update to 10.9.5. also errors pop up. So in short, i cant do **** anymore.

    Well ive tried some resets. Like the smc, nvram, pram. And removed the ram and put it back in. Also did the recovery things in the utility app. There were some errors there but they got restored. But nothing seems to fix the problem. So i dont know what to do anymore.
    Ive got a 13 inch late 2011. 2.4ghz. 10gb ram with a samsung ssd 750 evo 250gb.

    I hope somebody can help. Thanks a lot!

    Cheers
    Johnny
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #2
    I would suspect you might be having intermittent problems with a failing SATA hard drive cable to your SSD. Here are instructions on how to replace it:
    https://www.ifixit.com/Guide/MacBook+Pro+13-Inch+Unibody+Late+2011+Hard+Drive+Cable+Replacement/7655

    A way to test:
    Remove your SSD and place it in external 2.5" drive enclosure.
    Connect the external and boot to see if that helps/solves your problem. It will of course be slower since you are using USB 2, but you should not be getting kernel panics and be able to install things.
     
  3. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #3
    Have you run the Apple Hardware Test (your Mac is a 2011 device)?
    https://support.apple.com/en-us/HT201257

    I experienced exactly the same issues as you're describing with my late-2013 rMBP. One day, a KP while browsing the web and they got more frequent over 10 days until I couldn't keep the Mac running reliably, and finally gave up and ran a hardware test. The Apple Diagnostics tool (for 2013 and later Macs) led to the discovery that a memory module and another motherboard component were failing - Apple replaced the motherboard (with its soldered-in RAM) and all has worked since.
     
  4. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #4
    I agree with this. The symptoms sounds like what's likely to happen with bad RAM rather than what would happen with a bad SATA cable. Unfortunately, the memory test utilities supplied by Apple have historically not been particularly thorough and will often pass RAM that fails other tests. If your machine is capable of booting Memtest86+, that's a much better one (except that in some Macs, it instantly fails good RAM, since Apple failed to mark the memory addresses as read-only). Otherwise, you can run the memtest command line app that's bundled inside Rember from single-user mode.
     
  5. Munniemunnie thread starter macrumors newbie

    Joined:
    Feb 24, 2013
    #5
    Hi thanks for your replies. I did the AHT and it said it found a error: 4MEM/9/4000000: 0x83179f98.
    I've no idea what it means, but im gonna switch some ram memories and also do try to run the ssd through usb. See if anything helps.
     
  6. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #6
    From the reported 4MEM/9/4000000 error, it reads to me like one or more failed/defective RAM modules...
     
  7. Munniemunnie thread starter macrumors newbie

    Joined:
    Feb 24, 2013
    #7
    i removed the failing ram and now its working properly again. Thanks alot all!!
     

Share This Page