A modest Requestish

Discussion in 'Mac Programming' started by winstonzeddemor, Jun 25, 2010.

  1. winstonzeddemor macrumors newbie

    Joined:
    Jan 8, 2010
    #1
    So my problem started when I tried to delete the dmg version of Trolltech Qt, because I was going to install from source instead.

    The pearl script failed to remove all the files so I deleted them manually and got a little delete happy...I ended up removing /System/Library/Frameworks/QTKit.framework, which is the QuickTime components framework I imagine. (I know confusing, but I should have known better) Well the system was buggy after that; I got a friends mac who had Snow Leopard 10.6.3, tarred the file transferred it by FTP (because finder would keep crashing) and unpacked it and everything was back to normal.

    Turns out, her install of Snow Leopard did not include the symbolic link to the 'Headers', because I guess she did not have any developer stuff installed. So I get random compiler errors related to this.

    I was wondering if any of you developers (preferably with 10.6.4 and XCode 3.2.1 would be interested in:

    1.open terminal
    2.type 'sudo tar -cf QTKit.tar /System/Library/Frameworks/QTKit.framework'
    3.upload the tar somewhere
    4.post me a link to it

    it would be nice of you.
     
  2. FrogNL macrumors newbie

    Joined:
    Jun 19, 2010
    #2
    Here you are. :) Xcode. 3.2.3.

    Edit: Attaching to this post didn't work. You can find it at http://www.aizokroon.nl/QTKit.tar. Please reply when you have downloaded it, so I can remove it from my server again. :)
     
  3. winstonzeddemor thread starter macrumors newbie

    Joined:
    Jan 8, 2010
    #3
    thanks!

    you are a brillionaire (rich with brains), thanks

    EDIT: you have made my day, after a restart everything is normal again.
     
  4. FrogNL macrumors newbie

    Joined:
    Jun 19, 2010

Share This Page