A non-jailbreak (!!!), decent(!) DTS-capable video player

Discussion in 'iPad Apps' started by Menneisyys2, Nov 30, 2013.

  1. Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #1
    Today, I've been rigorously benchmarking the top iOS video player apps for my new It's Playing Pro 5.0 review. During this, I've also re-tested HD Player Pro so that I can publish the latest benchmark & battery usage results on iOS7.

    The player, which I recommended in many of my past articles, turned out to still support DTS and is a considerably better player than the two other DTS-capable, current AppStore player I know of, VLC and CineXPlayer. (Click the links for the reviews of the latest versions of both apps, should you want to know why I don't recommend them.)

    NOTE:

    1, it's no longer available in the AppStore. It seems the devs have played the same card as the developers of AVPlayerHD a year ago: upon receiving the DTS folks' request to eliminate DTS support, they haven't released a new, dumbed-down version of the player (without DTS support) but removed the app from the AppStore, which means

    a, earlier downloaded versions aren't overwritten (you don't need to manually save / overwrite IPA files, unlike with players that do have dumbed-down versions) and happily play DTS audio even now

    b, you can re-download the, as explained above, DTS-capable, last version from the AppStore on iDevices you've at least once directly downloaded any version of the player, before the devs had to remove the app.

    2, in iOS7, its hardware (e.g. MKV) decoding doesn't work when there's no Internet connection (for example, you enable Flight mode or don't connect to any network). Under iOS6, the player still worked just fine in Flight mode. Keep this in mind if you use it under iOS7.
     
  2. 007p macrumors 6502a

    Joined:
    Mar 7, 2012
    #2
    Is it me or is that really weird? Why would it require an internet connection :confused: I'd be interested to know what its doing with the internet connection when playing a video.
     
  3. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #3
    On my 3G data-enabled iPhone 5 (7.0.4), I've measured its data usage (using the built-in cellular & app-specific counter functionality iOS7).

    It seems it doesn't connect to anywhere. I've tried a exiting / restarting the app / the HW-decoded video in the app but the counter stayed at 0 bytes.

    That is, it doesn't "call home" (or anywhere). It seems to be safe. It just requires an active data connection under iOS7 - prolly because of a bug, as the devs couldn't update it for iOS7 without having to remove DTS support (and, consequently, screwing up their customers).
     

Share This Page