A possible fix for iCloud PUSH mail...

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by insocal, Nov 3, 2011.

  1. insocal macrumors regular

    Joined:
    Jul 31, 2007
    #1
    Just got off of yet another Chat with Apple Support. The rep I spoke with had me do the following...

    Go into Settings>Mail, Contacts, Calendars>Advanced...turn ALL to FETCH
    Go into Settings>Mail, Contacts, Calendars>Fetch New Data...turn Push OFF.

    Reboot Phone...Home/Power button held down at the same time.

    Go back into Settings>Mail, Contacts, Calendars>Fetch New Data...turn Push ON. Leave Advanced set to Fetch.

    Sent myself a Test e-mail from my MacBook Pro Mac Mail withOUT Mail open OR running in the background on the iPhone.

    The message arrived almost immediately.

    This is the first time I've received a 'solution' from ANYONE. I'm really hoping it's not a temporary fix.

    The rep's name was Jason and he told me he set up his iPhone the same way. Also told me I could take the credit when posting in the forums to help others but I assured him I wouldn't. :)

    Hope it works for all of us having trouble since moving over from MobileMe to iCloud.
     
  2. Oppressed macrumors 65816

    Oppressed

    Joined:
    Aug 15, 2010
  3. DeDe711 macrumors newbie

    Joined:
    Nov 9, 2011
    #3
    It worked for me!! Thank you for posting...this was driving me crazy!! :)
     
  4. 1putt macrumors newbie

    Joined:
    Nov 10, 2011
    #4
    Thanks worked for me too

    Thanks worked for me.

    Note to user that it did not work for.

    Make sure you get out of settings before you reboot or changes won't be saved.
     
  5. andy2141 macrumors 6502

    Joined:
    May 29, 2010
    Location:
    UK
  6. Burr510 macrumors member

    Burr510

    Joined:
    Nov 20, 2010
    Location:
    Pittsburgh
    #6
    unfortunately it did work for me... I'll try again later
     
  7. Bethany Smith macrumors member

    Bethany Smith

    Joined:
    Oct 11, 2011
    #7
    Worked for me! Thank you so much this was driving me absolutely bonkers.
     
  8. 78-bit macrumors newbie

    Joined:
    Sep 29, 2011
    #8
    I can confirm this works for both myself and a friend.
     
  9. russell2 macrumors member

    Joined:
    Jun 25, 2011
    #9
    Worked for me on my iPad 2 thanks my 4S has been working fine for some reason
     
  10. kavika411 macrumors 6502a

    kavika411

    Joined:
    Jan 8, 2006
    Location:
    Alabama
    #10
    Wow. That worked. It took several minutes to take effect, but for the first time since 5.0 I have push mail again. Thanks!
     
  11. SayMilesAway macrumors regular

    SayMilesAway

    Joined:
    Nov 11, 2011
    Location:
    Florida
    #11
    how come you guys are having problems with push? i haven't noticed any issues..
     
  12. DragonJade macrumors 6502

    Joined:
    May 2, 2009

Share This Page