A process called "cloudd" constantly consuming huge CPU resource

Discussion in 'OS X Yosemite (10.10)' started by qiaohaiyang, Jun 22, 2014.

  1. qiaohaiyang macrumors newbie

    Joined:
    Jun 22, 2014
    #1
    This process can not be stopped and drains out battery quickly. I only have 3-4 hours battery life.

    Do you guys find "cloudd" in your mac?
     

    Attached Files:

  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    That is a daemon process that deals with syncing iCloud data with your Mac and iCloud. It is a normal process for Macs to have running. You can likely disable it by signing out of iCloud, signing out of Messages/FaceTime, and turning off all iCloud syncing services.
     
  3. qiaohaiyang thread starter macrumors newbie

    Joined:
    Jun 22, 2014
    #3
    I got it. Thank you so much!
     
  4. rodknocker macrumors 6502

    Joined:
    Jul 4, 2011
    #4
    So you will say that a huge constantly consuming cpu of cloudd is normal?

    It isn't. I see the same here. It is definitely a bug.
     
  5. ZomBee macrumors member

    ZomBee

    Joined:
    Jun 5, 2014
    #5
    I had something similar, but it was called 'bird'. I disabled the syncing of documents and data (kept other icloud settings on) and that cleared up my problem. My computer was unusable a 'bird' was using 96% of my computer at all times. When I would kill the process, it would automatically start. Hope this is helpful to someone. :)
     
  6. rodknocker macrumors 6502

    Joined:
    Jul 4, 2011
    #6
    This helped. Thanks.
     
  7. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #7
    For non-final releases, yes this is normal.
     
  8. haravikk macrumors 65816

    Joined:
    May 1, 2005
    #8
    Except that it really isn't; there's a big difference between "normal" and "not unexpected". Bugs in non-final releases are absolutely to be expected, but that doesn't make them normal; the whole purpose of beta releases is to find them and get rid of them. Granted you can't take a beta release as indicative of what final performance will be like, but that doesn't mean you should just accept problems without doing something about them.


    Anyone experiencing issues with cloudd or other processes using up extra CPU should locate them in Activity Monitor, and generate a profile that they can send to apple at bugreport.apple.com. You can then use Activity Monitor to quit or, if necessary, force quit the offending process. This should force the process to relaunch, and hopefully behave itself, though until the cause of the high CPU usage is fixed it may become resource hungry again, but at least by sending a report you can help make sure that the issue is fixed. In this case if the process keeps reoffending then turning off iCloud Drive is your best bet, but get that profile first!
     
  9. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #9
    Apple hasn't fully worked out how to sync cloud documents with 10.10 yet. The high CPU usage could be the result of lots of little files, a few big files, files that are too big for iCloud, or any other number of unknown problems. It is expected to have normal bugs and other problem parts of a new and non-public product.
     
  10. rodknocker macrumors 6502

    Joined:
    Jul 4, 2011
    #10
    I will send a bug report in the next days to Apple.

    ----------

    Yes. iCloud Sync doesn't really work for me.

    And today is the Wipe of the CloudKit Section. I will try to turn on Document Sync on OS X Yosemite today again
     
  11. cschmelz macrumors 6502

    Joined:
    Jun 6, 2007
    #11
    My cloudd thread is using zero percent of CPU on DP3 on a slow MBA from 2010.

    Perhaps it is using a lot of CPU time to sync for first time?
     
  12. macgeneral macrumors newbie

    Joined:
    Oct 7, 2014
    #12
    had the same issue lately

    moving
    Code:
    ~/Library/Application Support/CloudDocs
    to the trash, killing the "bird" process in the activity monitor afterwards and then emptying the trash solved it for me (for now) - I didn't lose any iCloud files so far and it doesn't seem to redownload them....
     
  13. ploinkr macrumors newbie

    ploinkr

    Joined:
    Aug 8, 2013
    Location:
    Montreal
    #13
    Thanks @macgeneral ; worked for me temporarily but it's now back - that's in the GM v3 :confused:
     
  14. macgeneral macrumors newbie

    Joined:
    Oct 7, 2014
    #14
    yes, same here :/ I filed a bug report at Apple and I hope they fix it before the final release... The only thing that stops it is disabling iCloud drive (and waiting for a fix): it's worth it for me even if I can't use iCloud drive until then, but else it drains my MBP battery very fast.

     
  15. PJL500 macrumors regular

    Joined:
    Nov 27, 2011
    #15
    clouds seem to be a bug

    Yes. It has started since I downloaded the official public release of 10.10. It wants to cook my MBP!
     
  16. endobrendo macrumors newbie

    Joined:
    Apr 30, 2012
    #16
    Me too—cloudd and bird processes burning up my Mac after Yosemite upgrade

    WHat to do? I wish I had waited to upgrade now. It always works like this, the upgrade ruins my workflow until the bugs get fixed. Damn.
     
  17. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #17
    Same problem here, "bird" eats tons of CPU for hours (possibly forever?) and basically turns my MacBook Air into a hot, loud, 1-hour machine. Sad. And this is not a new sync, I set up iCloud Drive last week and everything was synced for that period, but now this bird process along with cloudd process won't stop.

    Wanted to replace Dropbox with iCloud Drive but with this (maybe a bug? maybe not?) it's simply not feasible, at least on a laptop. Back to Dropbox. Sigh.
     
  18. OldSchoolMacGuy macrumors 601

    OldSchoolMacGuy

    Joined:
    Jul 10, 2008
    #18
    Seeing it on my Mac mini too. Both bird and cloudd killing CPU to the point it's running the fan like crazy.
     
  19. PJL500 macrumors regular

    Joined:
    Nov 27, 2011
    #19
    cloudd in 10.10 is unstoppable.

    It kidnaps over 90% of cpu and will not let go - force quitting process does not stop it coming right back. It went on for 30 minutes in the middle of a movie! Had to abandon the movie.
     
  20. bjet767 macrumors 6502a

    Joined:
    Oct 2, 2010
    #20
    I had same problem and this fix it:

    Did a CMD-R refresh and viola, fix problem.

    Machine, Early 2014 MBA 11"

    Now I have to fix the sleep wake freeze on my 2012 quad i7 with Yosemite

    I still have GM 3, build 14A388a, and will download the public version from app store.
     
  21. macfreeknl macrumors newbie

    Joined:
    Oct 29, 2014
    #21
    My fix

    Thanks for all suggestions. In my case, both discoveryd and cloudd where both using 100% CPU.

    I killed discoveryd (perhaps this was unrelated) in the terminal (lauchd started it again, and all was fine)

    As for cloudd, I went to System Preferences > iCloud, and unchecked 'iCloud Drive". In a minute, the CPU load was back to <1%.

    To verify, I turned it back on, and indeed the CPU spiked again to 100% load. I'm not sure it this is due a one-time sync or something permanent, but for now I'm happy to turn this feature off.

    Thanks for all the suggestions.
     
  22. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #22
    I'm hoping there are a whole lot of engineers and executives working at Apple who are getting pissed off that their 12-hour MacBook Airs are suddenly getting under 2 hours of battery life. This needs to be fixed ASAP, it is unusable on laptops (which is now most of the Macs Apple sells).
     
  23. Abba1, Nov 2, 2014
    Last edited: Nov 2, 2014

    Abba1 macrumors regular

    Joined:
    Aug 6, 2014
    #23
    Regarding both Cloudd and Bird

    Neither Cloudd nor Bird should be using that much memory. In "Memory" look at Memory, Compressed Memory, and Real Memory and see if there are very significant differences. What I think most important is "Real Memory," but others might think otherwise. Also look at the usage in "CPU". This may be related to how much are you doing on iCloud or it may be a bug. Remember that data stored in iCloud or iCloud Drive is on Apple's servers, not your Mac. In any case, you should not have to disable either document or data sync. If the problem continues, you may have to contact Apple.
     
  24. HiRez, Nov 29, 2014
    Last edited: Nov 29, 2014

    HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #24
    When the poster says bird and cloudd are "using 96% of my computer", they mean CPU, not memory. These are processes associated with iCloud Drive that take over the CPU for very long amounts of time (even with no iCloud Drive activity), thus drastically reducing battery life as well as reducing interface responsiveness. The effect is much more noticeable on laptops than desktops (which mostly have higher-clocked quad-core chips, less thermal constraints, and where battery life is not a concern).
     
  25. Anuba macrumors 68040

    Anuba

    Joined:
    Feb 9, 2005
    #25
    My Apple ecosystem contracted the 'bird flu' this morning. I upgraded iCloud to 20GB and tried to bounce some big files. As a result, the 'bird' process is now eating close to 100% CPU on my three Macs. Apparently, big files trigger it. As long as you're merely dealing with a handful of Pages and Numbers docs of a few hundred kB each, you don't anger the bird.

    Disabling iCloud Drive and then re-enabling is supposed to make it go away, but it comes right back 15 minutes or so after re-enabling. So the penalty for upgrading to paid iCloud is that now I can't use the Drive at all, which is a major bummer because I need it for the iWork apps daily.

    Thanks Apple. Yosemite is your buggiest since the initial release of Leopard.
     

Share This Page