A real head scratcher

Discussion in 'Mac Basics and Help' started by cf817, Jun 2, 2010.

  1. cf817 macrumors newbie

    Joined:
    Jun 2, 2010
    #1
    So here's the deal, my macbook pro can't connect to the internet via the airport express or directly to the ethernet all of a sudden. But the POS PC laptop I have connects just fine. I didn't do anything different one day I wake up and it acts like this. It recognizes the signal, connects to airport, gets a good IP, just can't connect to server. I've reset airport, I've deleted system preferences from the library folder, I've reinstalled the network, I've fiddled with every preference available and still nada. I'm at my wits end, and so is apple support apparently because they couldn't figure it out and said to reinstall OSX. It's so maddening b/c the cheapo, practical pc connects just fine and the pricey sexy mac doesn't. It really odd b/c sometimes after fiddling for a while I can load 1 and only 1 webpage and then it goes back to not working. Also I will run network diagnostics and it will say my internet is working even though their are still yellow circles next to internet and server. sometimes I get all green lights and it still doesn't work. I'm at a loss, any suggestions would be very appreciated. Thanks.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Have you tried other browsers and apps if they would work?
     
  3. John Doe 57 macrumors 65816

    John Doe 57

    Joined:
    Jan 26, 2008
    Location:
    Los Angeles, CA
    #3
    Try this:
    1. Download OnyX (a free maintenance utility).

    10.6 Snow Leopard Link:
    http://www.macupdate.com/info.php/id/11582

    10.5 Leopard Link:
    http://pagesperso-orange.fr/joel.barriere/dl/105/OnyX.dmg

    10.4 Tiger Link:
    http://www.titanium.free.fr/dl/104/OnyX.dmg

    2. Open OnyX and Click Cancel on these two Alert Panels:
    -Cancel the S.M.A.R.T. Box
    -Cancel the Startup Volume Box

    3. Enter your Password

    4. Click on the Cleaning Tab

    5. In each tab, within the Cleaning Tab, execute the command. Check all the boxes in each tab. When its finished in that tab, it will ask you to reboot. Say NO. Go on to the next tab and repeat until all tabs, within the Cleaning Tab, are done. THEN REBOOT.
     

Share This Page