A regular audio cd keeps ejecting

Discussion in 'Mac Basics and Help' started by Gunhaver, May 21, 2007.

  1. Gunhaver macrumors member

    Joined:
    Nov 12, 2006
    #1
    On my PPC iMac with 10.4.9, a while ago the disk insertion mechanism stopped working right it wont "suck" the disk in anymore, but they will go fine if I just push it all the way, and occasionally a disk will get auto ejected right away, but it will usually work after another try or two, but I got an audio cd that I've been trying to insert, but it does nothing but make a some noise for a little while and then spit it back out without any message or warning at all. It's a cd from 96 (used, but in perfect condition) so it couldn't have any sort weird copy protection on it.
    Aaaaaaany idea why this could be happening? It seems more like a software problem since there's nothing weird about the disk and it's in perfect condition.
     
  2. Bobjob186 macrumors 6502

    Joined:
    Apr 16, 2005
    Location:
    Laguna Beach
    #2
    it's definately a disk problem, I've that problem before with lower quality cds or cds that are burned to fast.
     
  3. theISHkid macrumors regular

    Joined:
    Jan 29, 2004
    Location:
    Moore, OK
    #3
    Like Bob said... it's just something that happens every now and then. Is that the only CD that is giving you problems? I had one do that then a week later it worked.
     
  4. Gunhaver thread starter macrumors member

    Joined:
    Nov 12, 2006
    #4
    It's the only one that does that, but I haven't tried a very great number. Isn't there any way to like force the computer to insert the disk?
     

Share This Page