A Very unique sd card problem

Discussion in 'iMac' started by engg.dude, Sep 28, 2014.

  1. engg.dude macrumors newbie

    Joined:
    Sep 26, 2014
    Location:
    Navi Mumbai
    #1
    Hi,
    Finally I have got so much frustrated with my sd card slot that I am posting here for some kind of a solution.

    Background: I purchased a mid 2011 21.5 inch iMac about 2 years ago (Yes I know apple released 2012 version iMac then, but I got a real sweet deal). Started off with Lion, updated to Mountain Lion same day. Updated to Mavericks when it released and I also have a partition running Yosemite preview.

    The Problem: I like to tinker around with Raspberry Pi. Most of you might know it, but for others its small computer with sd card as its memory. You burn images of the OS into the sd card and plug it in the Pi. When I got pi, I had Mountain Lion running. I could read and write cards perfectly.

    Then after installing Mavericks, the sd card slot has now become read-only ! Not only that, but the name of the card(s) that I use all appears as "Untitled". I can copy paste files to the Mac, no issues, but can't write anything to the card. Nor am I able to repair/verify in Disk Utility.

    Also the iMac is not under warranty (nor was it when this issue cropped up), I even contacted my local Apple service, they said they could diagnose/solve the issue for a fee, but did not promise to guarantee a fix for the issue or money back.

    What I tried so far:
    1. I have maintained a bootable copy of Mountain Lion from which I could write to the card, but even booting from that partition does not work.

    2. Varied sd cards - I've tried everything from 1GB to 32GB cards from various manufacturers that are verified to work in other devices (digital camera, windows laptop, Motorola Moto X and Samsung Note 2). Even tried different formats like FAT 32, NTFS, HFS+ etc.

    3. Reinstalled/Clean installed different OS versions - Lion, Mountain Lion, Mavericks to no avail.

    4. Tried putting the switch on the sd card/ adapter to middle position as claimed by some users on the internet.

    5. Tired using the Terminal, but that too failed.

    6. Not to mention I did SMC and PRAM Reset **Edit**

    Things to know:
    I have never opened up my iMac.
    It has no physical damage. Never inserted things in sd card slot- like pins, toothpick etc.
    The non working sd card slot is not crucial, because I simply use the windows laptop, but it keeps bugging me that I can't diagnose the problem, or find a solution.

    Following is the screen grab of the info from finder
    Screen Shot 2014-09-28 at 9.17.18 pm.png

    This is what I see in Disk Utility. Of the 2 partitions, I can access one but not other.
    Screen Shot 2014-09-28 at 9.17.33 pm.png
     
  2. jji7skyline macrumors 6502

    jji7skyline

    Joined:
    Aug 10, 2011
    #2
    Something that a lot of people don't know is that the read only switch is checked physically, that is, the reader checks if the switch is on or off. It doesn't actually change anything inside the card.

    Therefore, the sensor that checks this is probably jammed or shorted or something. You can try to clean it out very carefully when the iMac is off, but there are better routes.

    - If you're under warranty, get it repaired properly.

    - Get a cheap SD card reader. They're so cheap on eBay, and sometimes come integrated into USB hubs.
     
  3. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
  4. engg.dude thread starter macrumors newbie

    Joined:
    Sep 26, 2014
    Location:
    Navi Mumbai
    #4
    Thankyou ! This is an angle that I did not consider.

    Yeah I have one. It works, but uses extra space

    No usb 3 ports. Cheaper to get USB 2 one.
     
  5. Batt4Christ macrumors member

    Batt4Christ

    Joined:
    Oct 14, 2014
    Location:
    Arkansas
    #5
    Similar issue

    I too am having issues with my SD Card slot in my MacBook Pro (13-inch, Mid 2010).

    Worked fine for me all the way through Mavericks. From the moment I began the Beta program and Yosemite... every SD Card is "Read Only". External readers work fine. I haven't rebooted into my other partition with Mavericks since beginning with the Beta (haven't really had time). But I had just used an SD card the week before the install with no issues reading or writing (or formatting) the card.
     

Share This Page