A Windows Networking Issue

Discussion in 'Macintosh Computers' started by realityisterror, Sep 22, 2003.

  1. realityisterror macrumors 65816


    Aug 30, 2003
    Snellville, GA
    Ok, this has nothing to do with Macs whatsoever, but since you guys (and gals) are awesome, I thought I'd ask you:) :)

    I have two computers (a 98SE and an XP) the xp box is hooked up to a D-link 802.11b router (DI-614+) the 98 machine has a USB wireless adapter (d-link DI-120+)

    the problem is that if i leave the USB adaptor plugged in to the machine, it won't start up properly (not at all)
    if i unplug the adapter and try to start up everything works fine then i have to re-plug it in

    my mom (this is primarily her computer) has trouble remembering to plug in and unplug (after shutting down) so i want to try and fix it for her (and so she won't yell for me to come fix it whenever she forgets ;) )

    i think it may have something to do with electricity remaining in the adaptor and then .... i don't know.... (i think i read that somewhere)

    any help for my mom (and me) would be greatly appreciated,
  2. keithcobbett macrumors member

    Jan 6, 2002
    Hillsborough, NH
    Have you tried hooking the USB adapter to the XP Machine? If not, try that and see if it even works. If it does, try getting another adapter for the Win98 Machine. Or reinstall the drivers and see if there are updated drivers. Win98 was bad with USB and networking at first. Got better, but wasn't great.
  3. acj macrumors 6502

    Feb 3, 2003
    perhaps a bios issue about USB booting enabled? Just a wild guess...
  4. tomf87 macrumors 65816


    Sep 10, 2003
    D-Link doesn't seem to manufacture a DI-120+ USB wireless adapter. They make a DWL-120+, so I assume this is what you're using.

    From http://support.dlink.com/faq/view.asp?prod_id=1377&question=DWL-120+ :

    After installing my DWL-120+, my Windows 98/Me machine will not boot up properly. What can I do to resolve this?

    A simple solution is to disconnect the DWL-120+ from the computer until the computer is completely booted up and then reconnect. You can disconnect the cable from the unit itself, not the back of the computer.

    The problem may be solved by the following:
    Upgrade the BIOS on your computer.
    Make sure you have the latest Windows updates
    Verify you have the latest drivers for your USB Controller (usually solved by #1 and 2).
    Connect the DWL-120+ directly to the back of the computer. Do not use the USB ports on a keyboard or the front of the computer, or connect to an USB hub.
    If you have an Intel 82801 USB Controller, please visit and load the Intel INF update which has corrected this issue. Make sure you uninstall the DWL-120+ AND any other wireless utilities before running this update. When update is complete, then reinstall the DWL-120+.

    The Intel INF update was linked to here:

  5. realityisterror thread starter macrumors 65816


    Aug 30, 2003
    Snellville, GA
    thanks but i've tried that....
    the inf update thing didn't help...
    too bad...

Share This Page