A word of warning...

Discussion in 'OS X El Capitan (10.11)' started by randomgeeza, Jun 9, 2015.

  1. randomgeeza macrumors 6502

    Joined:
    Aug 12, 2014
    Location:
    United Kingdom
    #1
    A word of warning:

    I installed 10.11 on a second partition, but having looked through the OS decided to wait this one out for now. On the understanding that I could remove the partition and resize Yosemite back to normal...

    It wouldn't let me... Tried everything, from Yosemite, DU back to El Cap's DU, all partition + and - buttons were greyed out. Tried Cmd R DU... buttons weren't greyed out, but the DU was El Cap's new UI version... And not knowing what to do. I ended up deleting everything...

    Suffice it to say, I had done a CCC moments before fiddling with the Beta, for such an event like this. And I am back up and running.

    However, if you are a little flaky on the inner workings of DU and/or trying Beta's out. My advice, install it on an external and not on a second partition unless you are confident, and know your way around DU and Cmd R.

    Toodle pip and tally ho!
     
  2. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #2
    Thanks for this @randomgeeza. I was going to clean install my MBA back to Yosemite as one of my apps is broken on El Cap and then install it as a partition. Maybe I'll try to install Yosemite on an El Cap partition and see if that partition can be removed after....just to see. But I do also have a spare SSD so options are good.
     
  3. BasicGreatGuy, Jun 9, 2015
    Last edited: Jun 9, 2015

    BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #3
    I just got done installing El Capitan on a separate partition when I saw your post. Not good news. I have a CCC and TimeMachine backup. Still don't like the thought of having to go that route just to delete the partition (if needed).
     
  4. batting1000 macrumors 604

    Joined:
    Sep 4, 2011
    Location:
    Florida
    #4
    Saw this post after installing as well. Will have to try some things after. Liking El Cap though.
     
  5. Mlrollin91 macrumors G4

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #5
    I did this last year with Yosemite, and my Mavericks partition would not resize back to full. I ended up losing about 5GB. I was able to resize it from 100GB to 5GB, but thats it. I figured for 5GB its not worth wiping my Mac and starting fresh.
     
  6. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #6
    I got to thinking...This same problem popped up with the Yosemite Beta etc. People were having a hard time deleting their beta partitions, because Yosemite had converted their HD to core storage. Once the drive was reverted, deletion of the partition could occur. I think the same problem may be happening here. I haven't tested my theory, yet. But for those who would like to test, take a look at the following thread.

    http://forums.macrumors.com/threads...ew-up-partitions.1741742/page-2#post-19207476
     
  7. AustinIllini macrumors demi-god

    AustinIllini

    Joined:
    Oct 20, 2011
    Location:
    Austin, TX
  8. E3BK macrumors 68020

    E3BK

    Joined:
    Mar 15, 2008
    Location:
    NYC
    #8
    Yeah, I tried to create a partition on the SSD that I upgraded to El Cap. It seemed to be ok but then I got operation failed. So the main El Cap partition is 180GB and the 60GB I was trying to create is not usable. So I tried to delete the bad partition. The 60gb is no longer listed but the main El Cap partition was not able to recover the 60GB back. Interesting.

    So I'm clean installing back to Yosemite and will install El Cap on an external once I submit a report. I guess I should go make an El Cap boot disk.
     
  9. colinwil macrumors regular

    Joined:
    Nov 15, 2010
    Location:
    Reading, UK
    #9
    It seems to be letting me on my Macbook Pro 2009

    1. Originally I had Yosemite on a 750gb partition on my 1TB Crucial SSD, with the remaining 250gb for bootcamp
    2. I repartioned it so my Yosemite partition was 600gb and the new partition was 150gb. I ignored the warning that said that Bootcamp may not be bootable - I don't use it anyway.
    3. I installed El Capitain on the new partition
    4. After playing with El Capitain for a bit, I rebooted back into Yosemite.
    5. First I wanted to check whether it had really affected my Bootcamp - so I went to System Preferences and set the boot volume to Bootcamp. It failed to boot - saying that that there was no bootable disk. I rebooted again with the option key and selected my original Yosemite boot partition which worked.

    6. I noticed this post so I thought I'd try it. I went into Disk Utility (in Yosemite), selected the partition where I'd installed El Capitain, and the '-' sign was working. I clicked it, deleted the partition, and resized the original one back to 750gb with no problems.

    7. Once I'd deleted ElCapitain and was back in Yosemite, I thought I'd try Bootcamp again now that that partitions were back to how they'd been before I started. It still didn't work - so be aware - Apple's not lying when it says that repartitioning may break Bootcamp!
     
  10. SlCKB0Y macrumors 68040

    SlCKB0Y

    Joined:
    Feb 25, 2012
    Location:
    Sydney, Australia
    #10
    You just had to issue a command to the terminal to remove core storage logical volumes and reboot and it would have been fixed.
     

Share This Page