A word on breaking 2.1.1

Discussion in 'iPod touch Hacks' started by HOEN, Sep 16, 2008.

  1. HOEN macrumors newbie

    Joined:
    Sep 16, 2008
    #1
    Ok, so to start off (knowing this is my first post and without an introduction that looks bad on my part) I have tried various things since receiving my ipod touch at 9am this morning, and have done nothing but rode the fail train all day. That is demoralizing, to say the least.


    I am of course on 2.1.1 firmware. I've tried to DOWNGRADE to 2.0.1 because there's plenty tutorials on breaking that, amirite? I have no troubles creating the custom firmware with quickpwn, and thank god for that app. Real good stuff, but once i go into recovery mode with my ipod touch and start up itunes to manually select which firmware I would like to recover with, I get nothing but errors.

    Actually, I couldn't even downgrade. Simply would not let me.

    Has anyone ran into familiar problems? I tried rooting around the first couple of pages, but found mostly threads similar to "LOL WHEN DEY GONNA FIX 2.1.1" and well, that's not what I'm asking.


    tl;dr

    Why can't I downgrade my 2.1.1 ipod touch to an already cracked firmware?
     
  2. macbooker15 macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Hello! I'm over here!
    #2
    I want to say new hardware....can anybody back me up?
     
  3. YodaEXE macrumors member

    Joined:
    Sep 11, 2008
    #3
    If you looked closer at the other threads, you'd find that the 2nd gen has slightly different hardware than the 1st gen, and thus there's no jailbreak for it yet.
     
  4. fiftyfour123 macrumors member

    Joined:
    Feb 26, 2008
    Location:
    New York, NY
  5. HOEN thread starter macrumors newbie

    Joined:
    Sep 16, 2008
    #5
    **** rly?

    Ah, I knew that 2.1 hadn't been broken yet, but I had no clue it was an actual hardware issue that is being dealt with by those leet bastards who do all the grunt work with these things. Bless them, really.


    Thanks for the tip, sleuths. I'll be in touch.
     
  6. brightshadow360 macrumors member

    Joined:
    Sep 11, 2008
    #6
    did yours come with 2.x software? if so, it's likely that you have the new one that apple seems to have blocked through it's hardware. the reson it won't downgrade is probobly due to it either being unable to or because apple is trying to stop jailbreaks. however, there is one other posibility. I had a simmilar problem when trying to upgrade.

    your restore file, have you moved it into a folder called "ipod touch updates"? if not, search for it (it won't be in the itunes program folder. it will be in a less ovious itunes folder. just search). move it there and open itunes and try again.
     
  7. HOEN thread starter macrumors newbie

    Joined:
    Sep 16, 2008
    #7
    I hadn't though to put my restore file in that folder, I had been using the alt restore command.
     
  8. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #8
    if you have a new ipod touch don't even bother trying the current 1st gen method it will not work no matter how hard you try or even putting the ipsw in the updates folder.

    it's all a hardware issue, the dev team went on record a few months ago and said the custom restore will never die untill apple do a hardware change............... apple release new ipod, change hardware and fix the exploit so if you have a new ipod touch just be patient and wait, the dev team have made some progress with the new ipods so it shouldn't be too long to wait hopefully.

    http://blog.iphone-dev.org/post/50363303/u-cant-touch-this
     

Share This Page