a1278 mid 2010 no charger

Discussion in 'MacBook Pro' started by skersiukas, Oct 11, 2014.

  1. skersiukas macrumors newbie

    Joined:
    Oct 11, 2014
    #1
    Hello gays ;) i have problem with my macbook pro 13 mid 2010 a1278. No green or orange light on charger and no charger battery :( change new battery, new charger, new magsafe, still no light or charger :( help please! how fix?
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    What do the battery status lights show when you press the test button on the side of your MBPro? You should at least see the normal indication that the battery is recognized (the lights will light back and forth in a chase pattern)

    Have you tried the SMC reset? http://support.apple.com/kb/HT3964?viewlocale=en_US&locale=en_US

    If you have tried a different battery, different power adapter, and also replaced the internal magsafe connector, and there's no indication of any power or charge on the battery (and no lights appear on the battery status panel), then your logic board is the only part left... :(
     
  3. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #3
    yes indicator show 3 light battery stay 41%. smc not help

    ----------

    whan plug adapter is recognised show battery light unplug olso show light
     
  4. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #4
    on battery health program show: charging with 0.0 watts unplug end plug power show same time 1.6 -2.5 watts. what can be? i need this mac for job :(
     
  5. DeltaMac, Oct 11, 2014
    Last edited: Oct 11, 2014

    DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    If you have no light on the Magsafe connector, boot up your MBPro.
    What happens to the battery icon on your menubar when you plug in your Magsafe adapter? Does it change from a battery to a plug with lightning bolt.

    If the menubar icon changes, wait a few seconds, then unplug your adapter. Does the icon change again?


    Is your internal Magsafe connector (where you plug in your power adapter) clean and undamaged?
     
  6. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #6
    connect power adapter icon change: on icon show power plug ( power source: power adapter) (battery is not charging) unplug: icon show battery (power source: battery ) (calculating power remaining...) no light on charger. magsafe board is new

    ----------

    battery health : 99%, battery status : Good, cycles: 3, battery temperature 30C
     
  7. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #7
    maybe burn power charger ic chip? olso way no light on charger connector?
     
  8. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Remove bottom case, disconnect the battery, and check the condition of the logic board battery connector.
    Carefully reseat that battery connector.

    Inspect and reseat the Magsafe board connector on the logic board.

    If your magsafe board is new, and the magsafe adapter is different, and you have replaced the battery, and you run on adapter power, and also can run on battery, but the battery does NOT charge, then there's only one part left - the logic board.

    (Be sure to try a third power adapter - an Apple store may let you test one)
     
  9. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #9
    mac run on battery if unplug battery only which power adapter no start, one minute i open case unplug battery end check witch tester power

    ----------

    power adapter, battery, magsafe board i bay apple centre is original part for my macbook

    ----------

    i check battery connect start check left side:
    0:0:0:3.43:0:3.43:12.59:12.59:12.59 volts on power connector
     
  10. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    I really do want to help you, but your posts are getting much more difficult for me to understand ...

    For example - you confused me now when you posted
    Does that mean that you bought replacement parts on Ebay?
    Or are you using the original parts that came with your MBPro now?
    Or did you get Apple parts (from an Apple service centre), and those are the replacement parts that you are now using?
    Or, you mean something else....?

    Just curious - is English your primary language?
     
  11. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #11
    no its not for ebay i bay from apple repair centre new parts about 2weeks ago in my country. i from lithuania. thursday stop working charger light and no charger battery i change this new parts but no working
     
  12. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #12
    I think you wasted your money on the repair parts, although those were the most likely fault.
    Your battery will continue to lose charge until you get this repaired.

    Take your Macbook Pro in for service.

    Or - you can use your MBPro by always plugging in to power.
    In my opinion, nothing will help until you get the logic board replaced.
     
  13. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #13
    I'm try swap logic board to friend computer its same model like me . end parts working correctly mac power on, power adapter light on battery charger. so its my logic power fault? possible power charger ic chip fault ?
     
  14. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #14
    Thank you for try help my. I live tomorrow repair centre for diagnostic if fix i write wits by wrong way no light and charger ;) see you later
     
  15. skersiukas, Oct 13, 2014
    Last edited: Oct 13, 2014

    skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #15
    Try fixed

    Hello again. I went to the repair center, the center say not fixed my computer, can just replace the logic board, the price about 300-400 pounds.

    It bought a new one mac.

    I got another logic board fault GPU.
    But connect charger connector is show green light, connect the battery orange light comes on end battery charger.
    Now battery have 4 cycles fully charger 100%.

    Need your help gays,

    So why green-orange light does not turn on?
    What can be burned out?
    I'm try for another board to swap good components.

    I waiting gays your ideas where can by burn.

    thank you for help.
     
  16. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #16
    Later i test board resistor end ic voltage on my board. I show for you gays board picture with voltage maybe its help found something wrong ;)

    Maybe same one have macbook pro 13 mid 2010 a1278 board repair manual ? Its by easy for my search fault components
     
  17. skersiukas thread starter macrumors newbie

    Joined:
    Oct 11, 2014
    #17
    Hello. fixed my problem ;) is burn u7000 chip soldering new chip wooola battery charging :D
     

Share This Page