A1304 MacBook Air 2.1 charging problem

Discussion in 'MacBook Air' started by dvalente, Nov 22, 2014.

  1. dvalente macrumors newbie

    Joined:
    Nov 17, 2014
    #1
    Hi everyone!
    Just came to me a MacBook Air with this power problem.
    Normal press button to start doesn't work if battery is unplugged or discharged.
    Works fine with charged battery.
    MagSafe doesn't give any light with or without battery (same symptoms with diferent charger).
    Won't charge battery (diferent battery and diferent MagSafe same symptoms).
    Changed the MagSafe connector unit in the mac air and does the same things.
    Tested the MagSafe connector with another same model mboard and it works normal, green and orange light when charging battery in MagSafe.
    So, narrowed to the mboard, and surely it's a problem in the power/battery zone. But I don't know what cold be the component in it that causes this.
    Can anyone enlighten me of what could be the source of this problem?
    Thanks.
     
  2. dvalente thread starter macrumors newbie

    Joined:
    Nov 17, 2014
  3. chogue23 macrumors member

    Joined:
    Mar 16, 2015
    Location:
    Waco, TX, USA
    #3
    Try resetting the SMC? Thats an odd problem to have, and I hope someone else can help!
     
  4. dvalente thread starter macrumors newbie

    Joined:
    Nov 17, 2014
    #4
    Tried all kind of resets...Nothing makes it back to normal.
    There is something burned but simply can't figure out what.
    :mad:
     
  5. Airboy1466 macrumors regular

    Airboy1466

    Joined:
    Feb 23, 2015
    #5
    seems like we are having the exact same issue my friend I had to replace the power adapter apple sent me one free because I’m under warranty But do an apple hardware test and post back here what the results are

    to enter the hardware test Press the power button then immediately hold down the D key until you see a globe saying entering recover mode then follow the on screen instructions at end of test you should get error codes make sure your magsafe is plugged in
     
  6. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #6
    Have you tried taking it to Apple?
     
  7. dvalente, Apr 1, 2015
    Last edited: Apr 1, 2015

    dvalente thread starter macrumors newbie

    Joined:
    Nov 17, 2014
    #7
    Yes, I have! In apple care they wanted to fit a new logic board. Well, that I can do myself, no thank´s. Spending 400€ on a new board is not an answer.

    The D key only works if I have the second installation disk from 10.5, and an external cd reader. Wich I don´t have... :/
    Tried this instructions from here http://rivenbyfive.blogspot.co.uk/2012/01/download-and-run-apple-hardware-test.html but could´t boot either to the Apple Hardware Test program.
    How can I do it in a Mackbook Air 2008?

    Also discovered that istat doesn´t detect any of the macbook sensors. Neither fan or temperature appears in istat. It also doesn´t sleep when I close the Macbook lid...
     
  8. Airboy1466 macrumors regular

    Airboy1466

    Joined:
    Feb 23, 2015
    #8
    Which version of OS X are you running
     
  9. dvalente thread starter macrumors newbie

    Joined:
    Nov 17, 2014
    #9
    Used lion, mountain lion, mavericks and now is with yosemite.
     

Share This Page